summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD35
-rw-r--r--seci-coin-qt.desktop11
-rw-r--r--seci-coin-qt.install11
5 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c95eea16ddf4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = seci-coin-qt
+ pkgdesc = Cryptocurrency wallet(QT)
+ pkgver = 1.15.1.1
+ pkgrel = 1
+ url = https://seci.io/
+ install = seci-coin-qt.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = qt5-tools
+ depends = boost-libs
+ depends = qt5-base
+ depends = qrencode
+ depends = miniupnpc
+ depends = db4.8
+ depends = zeromq
+ depends = protobuf
+ depends = libevent
+ conflicts = seci-coin
+ source = seci-coin-qt::git+https://github.com/Seci-Coin/Seci.git#tag=1.15.1.1
+ source = seci-coin-qt.desktop
+ sha256sums = SKIP
+ sha256sums = 11458f169fb1a43c20b998fa3cfce49519721e8cfe0b1d4976870326a594e8cf
+
+pkgname = seci-coin-qt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1e2b0c0734b7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..105aeccc91c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: metscoin <mets_coin@outlook.com>
+
+pkgname=seci-coin-qt
+pkgver=1.15.1.1
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://seci.io/"
+license=('MIT')
+pkgdesc="Cryptocurrency wallet(QT)"
+depends=(boost-libs qt5-base qrencode miniupnpc db4.8 zeromq protobuf libevent)
+makedepends=(boost qt5-tools)
+conflicts=(seci-coin)
+install=seci-coin-qt.install
+source=("${pkgname%-git}::git+https://github.com/Seci-Coin/Seci.git#tag=${pkgver}"
+ "$pkgname.desktop")
+sha256sums=('SKIP'
+ '11458f169fb1a43c20b998fa3cfce49519721e8cfe0b1d4976870326a594e8cf')
+
+build() {
+ cd "$srcdir/$pkgname"
+ find . -type f -iname "*.sh" -exec chmod +x {} \;
+ ./autogen.sh
+ chmod +x ./configure
+ ./configure --with-gui=qt5 --disable-tests
+ make
+}
+
+
+package() {
+ install -Dm644 seci-coin-qt.desktop "$pkgdir"/usr/share/applications/seci-coin.desktop
+ cd "$srcdir/$pkgname"
+ install -Dm755 src/qt/seci-qt "$pkgdir"/usr/bin/seci-coin-qt
+ install -Dm644 share/pixmaps/seci128.png "$pkgdir"/usr/share/pixmaps/seci-coin128.png
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/seci-coin-qt.desktop b/seci-coin-qt.desktop
new file mode 100644
index 000000000000..26c4f038e2da
--- /dev/null
+++ b/seci-coin-qt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Seci
+Comment=Seci P2P Cryptocurrency
+Exec=/usr/bin/seci-coin-qt
+Terminal=false
+Type=Application
+Icon=/usr/share/pixmaps/seci-coin128.png
+MimeType=x-scheme-handler/seci-coin;
+Categories=Office;
+Name[en_US]=seci-coin-qt.desktop
diff --git a/seci-coin-qt.install b/seci-coin-qt.install
new file mode 100644
index 000000000000..f98ba7338938
--- /dev/null
+++ b/seci-coin-qt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}