summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6156a616b63b..0ed87d459a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = secilc
pkgdesc = SELinux Common Intermediate Language Compiler
- pkgver = 2.6
+ pkgver = 2.7
pkgrel = 1
url = https://github.com/SELinuxProject/cil/wiki
arch = i686
arch = x86_64
groups = selinux
- license = GPL
+ license = custom
makedepends = xmlto
makedepends = docbook-xml
makedepends = docbook-xsl
- depends = libsepol>=2.6
- source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/secilc-2.6.tar.gz
- sha256sums = a84838c15bb7b0141238b48294b15ff0e1618107f547541a0067d1ddabcc9502
+ depends = libsepol>=2.7
+ source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/secilc-2.7.tar.gz
+ sha256sums = 9ec63dd64645c718f66d33c96299adfe0445b0aa62d7ac8c642f873c570609c5
pkgname = secilc
diff --git a/PKGBUILD b/PKGBUILD
index 6dffcb7a5abf..739f4148f42a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgname=secilc
-pkgver=2.6
+pkgver=2.7
pkgrel=1
pkgdesc="SELinux Common Intermediate Language Compiler"
groups=('selinux')
arch=('i686' 'x86_64')
url='https://github.com/SELinuxProject/cil/wiki'
-license=('GPL')
+license=('custom')
makedepends=('xmlto' 'docbook-xml' 'docbook-xsl')
-depends=('libsepol>=2.6')
-source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20161014/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('a84838c15bb7b0141238b48294b15ff0e1618107f547541a0067d1ddabcc9502')
+depends=('libsepol>=2.7')
+source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20170804/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('9ec63dd64645c718f66d33c96299adfe0445b0aa62d7ac8c642f873c570609c5')
build() {
cd "${pkgname}-${pkgver}"
@@ -23,7 +23,9 @@ check() {
make test
}
-package(){
+package() {
cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
+
+ install -Dm 0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}