summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--make-openssl.patch33
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a3caa124e3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed May 23 08:38:41 UTC 2018
+pkgbase = secpwgen
+ pkgdesc = Secure password generator
+ pkgver = 1.3
+ pkgrel = 4
+ url = http://zvrba.net/
+ arch = x86_64
+ license = MIT
+ makedepends = openssl
+ source = https://github.com/itoffshore/secpwgen/archive/v1.3.tar.gz
+ source = make-openssl.patch
+ sha512sums = a18b5405ae5f6a62c25dd61654ea897b2f099fa459530bc6cfdbe79d96bfa6b4943e4ba2456ad5355d37cababe585299638afe56ff1a9fc649b6df0b7aa1e269
+ sha512sums = SKIP
+
+pkgname = secpwgen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0adc41d05f21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kovshov K.A. <kirillnow at gmail dot com>
+# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
+# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
+
+pkgname=secpwgen
+pkgver=1.3
+pkgrel=4
+pkgdesc="Secure password generator"
+url='http://zvrba.net/'
+arch=('x86_64')
+license=('MIT')
+makedepends=('openssl')
+source=("https://github.com/itoffshore/$pkgname/archive/v$pkgver.tar.gz"
+ "make-openssl.patch")
+sha512sums=('a18b5405ae5f6a62c25dd61654ea897b2f099fa459530bc6cfdbe79d96bfa6b4943e4ba2456ad5355d37cababe585299638afe56ff1a9fc649b6df0b7aa1e269'
+ 'SKIP')
+
+prepare() {
+ cd ${pkgname}-${pkgver}
+ patch -p1 < "${srcdir}/make-openssl.patch"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ mv Makefile.proto Makefile
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ mkdir -p "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/man/man1
+ install -m 755 secpwgen "$pkgdir"/usr/bin
+ install -m 644 secpwgen.1 "$pkgdir"/usr/share/man/man1
+} \ No newline at end of file
diff --git a/make-openssl.patch b/make-openssl.patch
new file mode 100644
index 000000000000..3f2fa14ccb3d
--- /dev/null
+++ b/make-openssl.patch
@@ -0,0 +1,33 @@
+--- secpwgen-1.3/Makefile.proto 2015-07-21 20:15:10.000000000 +0000
++++ secpwgen-1.3/Makefile.proto.new 2015-07-21 22:03:47.511905311 +0000
+@@ -30,9 +30,9 @@
+ ##
+ # If using OpenSSL, uncomment the following 3 lines.
+ ##
+-#CRYPTO_CFLAGS =
+-#CRYPTO_OBJS = secure_random_openssl.o
+-#CRYPTO_LIBS = -lcrypto
++CRYPTO_CFLAGS =
++CRYPTO_OBJS = secure_random_openssl.o
++CRYPTO_LIBS = -lcrypto
+
+ ##
+ # If using cryptlib, uncomment the following 3 lines.
+@@ -45,7 +45,7 @@
+ # Change PREFIX to install to different directories. The binary is installed
+ # in $PREFIX/bin, and the man in $PREFIX/man/man1
+ ##
+-PREFIX = /usr/local
++PREFIX = /usr
+
+ ##
+ # On some operating systems (most notably Linux 2.6 kernels) using mlockall
+@@ -60,7 +60,7 @@ PREFIX = /usr/local
+ # Sometimes you have only dynamic libraries available. In that case COMMENT
+ # the following line.
+ ##
+-LINK_STATIC = -static
++#LINK_STATIC = -static
+
+ ##############################################################################
+ # NO USER MODIFIABLE PARTS AFTER THIS POINT \ No newline at end of file