summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.Changelog32
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD52
-rw-r--r--selfspy.conf92
-rw-r--r--selfspy.install19
-rw-r--r--selfspy@.service19
6 files changed, 247 insertions, 0 deletions
diff --git a/.Changelog b/.Changelog
new file mode 100644
index 000000000000..717d6b8245a5
--- /dev/null
+++ b/.Changelog
@@ -0,0 +1,32 @@
+2014-10-24 jakob <grandchild@gmx.net>
+
+ * 0.1.4.r169.g363aa5f-3 :
+ Update config file to include fixed parameters.
+
+2014-10-24 jakob <grandchild@gmx.net>
+
+ * 0.1.4.r169.g363aa5f-2 :
+ Add service and conf to src array.
+
+2014-10-23 jakob <grandchild@gmx.net>
+
+ * 0.1.4.r169.g363aa5f-1 :
+ Merge requirements patch into upstream.
+ Add pkgver() function and change versioning scheme.
+ Update pkgdesc.
+
+2014-10-06 jakob <grandchild@gmx.net>
+
+ * 20141005-3 :
+ Fix wrong setup files.
+
+2014-10-06 jakob <grandchild@gmx.net>
+
+ * 20141005-2 :
+ Add systemd service file.
+ Add example config file.
+
+2014-10-05 jakob <grandchild@gmx.net>
+
+ * 20141005-2 :
+ Rewrite PKBUILD to fit new src tree structure.
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..443419c20be7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 9 10:28:07 UTC 2015
+pkgbase = selfspy-git
+ pkgdesc = X11 personal keylogger daemon with statistical analysis.
+ pkgver = 0.1.4.r169.g363aa5f
+ pkgrel = 3
+ epoch = 1
+ url = https://github.com/gurgeh/selfspy
+ install = selfspy.install
+ changelog = .Changelog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-daemon
+ depends = python2-lockfile
+ depends = python2-keyring
+ depends = python2-xlib
+ depends = python2-sqlalchemy
+ depends = tk
+ depends = pycrypto
+ provides = selfspy
+ conflicts = selfspy
+ source = git://github.com/gurgeh/selfspy.git
+ source = selfspy.conf
+ source = selfspy@.service
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = selfspy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca9caab584fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: jakob <grandchild@gmx.net>
+
+pkgname=selfspy-git
+_pkgname=selfspy
+pkgver=0.1.4.r169.g363aa5f
+pkgrel=3
+epoch=1
+pkgdesc="X11 personal keylogger daemon with statistical analysis."
+url="https://github.com/gurgeh/selfspy"
+install=selfspy.install
+changelog=.Changelog
+license="GPL"
+arch=('i686' 'x86_64')
+provides=('selfspy')
+conflicts=('selfspy')
+depends=('python2'
+ 'python2-daemon'
+ 'python2-lockfile'
+ 'python2-keyring'
+ 'python2-xlib'
+ 'python2-sqlalchemy'
+ 'tk'
+ 'pycrypto')
+makedepends=('git')
+source=('git://github.com/gurgeh/selfspy.git'
+ "${_pkgname}.conf"
+ "${_pkgname}@.service")
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $srcdir/${_pkgname}
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $srcdir/${_pkgname}
+ sed -i 's/env python/env python2/g' selfspy/__init__.py
+ sed -i 's:var/lib:usr/share:g' Makefile
+}
+
+package() {
+ cd $srcdir/${_pkgname}
+ install -d $pkgdir/usr/{bin,share/selfspy}
+ install -d $pkgdir/usr/lib/systemd/system
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 $srcdir/../${_pkgname}@.service \
+ $pkgdir/usr/lib/systemd/system/
+ install -Dm644 $srcdir/../${_pkgname}.conf \
+ $pkgdir/usr/share/${_pkgname}/${_pkgname}.conf.example
+}
diff --git a/selfspy.conf b/selfspy.conf
new file mode 100644
index 000000000000..1dcfbab8259a
--- /dev/null
+++ b/selfspy.conf
@@ -0,0 +1,92 @@
+# Example selfspy.conf. Put this in your ~/.config/ to use it
+# with the systemd .service file.
+# Note: You cannot indent lines in here!
+
+
+# Defaults, used by both selfspy and selfstats.
+[Defaults]
+
+# Don't use quotes around the password, they'd be part of it!
+# Example:
+# PASSWORD=the passphrase can contain spaces
+PASSWORD=
+
+# You don't have to quote this either, but you can.
+DATA-DIR="~/.selfspy"
+
+
+# Selfstats default actions, when started with -c option.
+# Copy this to new files to make configs for common tasks.
+[Selfstats]
+
+## Summary statistics. Enabling any of these will suppress the
+## default list output and add the respective summary output.
+## The argument number will determine how many seconds after
+## a mouse click or keystroke you are still considered active.
+
+# Total time spent active
+#active=180
+
+# List window titles, sorted by time spent in them.
+#tactive=180
+
+# List processes, sorted by time spent in them.
+#pactive=180
+
+# List active periods, sorted by date.
+#periods=180
+
+# List click-to-type and other ratios. Useful as a rough
+# measure of effectiveness.
+#ratios=180
+
+# List processes sorted by keystrokes received.
+#pkeys=True
+
+# List window titles sorted by keystrokes received.
+#tkeys=True
+
+# Show logs since (most useful on the command line)
+#back=1 h
+
+# Time to start the log from.
+#clock=00:00
+
+# Date to start the log from.
+#date=2014 10 06
+#date=10 06
+#date=06
+
+# Limit results, format depends on whether --date/--clock or --id is used
+#limit=10
+
+
+## List filtering options
+
+# Show from this log id onwards. Set number of entries with --limit.
+#id=120
+
+# This requires a valid password above or you will be prompted.
+#showtext=true
+
+# Regex of window titles
+#title=chromium|firefox
+
+# Regex of text to search for
+#body=printer
+
+
+## Other options
+
+# Slightly more readable texts, eliminates display of
+# backspace edits.
+human-readable=true
+
+
+
+
+## Buggy parameters
+
+# This option is buggy from both here and the command line.
+##min-keys=10
+##key-freqs=true
diff --git a/selfspy.install b/selfspy.install
new file mode 100644
index 000000000000..e7dae7242768
--- /dev/null
+++ b/selfspy.install
@@ -0,0 +1,19 @@
+post_upgrade() {
+ post_install
+}
+
+post_install() {
+cat << EOF
+ Before running selfspy or the systemd .service for the
+ first time, copy the example config file from
+ /usr/share/selfspy/selfspy.conf.example
+ to your config dir
+ e.g. ~/.config/selfspy.conf
+ and ENTER A PASSPHRASE.
+
+ You can then start selfspy via
+ # systemctl start selfspy@user.service
+ or by hand with
+ $ selfspy -c ~/.config/selfspy.conf
+EOF
+}
diff --git a/selfspy@.service b/selfspy@.service
new file mode 100644
index 000000000000..587300d7097a
--- /dev/null
+++ b/selfspy@.service
@@ -0,0 +1,19 @@
+[Unit]
+Description=Log everything %I does on the computer
+
+# Not really needed. Just to make it start as late
+# as possible before graphical.target, since we are
+# actually waiting for X11 and don't want to spam
+# the journal
+After=multi-user.target
+
+[Service]
+Type=simple
+User=%I
+Environment=DISPLAY=:0
+ExecStart=/usr/bin/selfspy --config "/home/%I/.config/selfspy.conf"
+Restart=on-abort
+ExecStopPost=/usr/bin/rm -f "/home/%I/.selfspy/selfspy.pid.lock"
+
+[Install]
+WantedBy=graphical.target