summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
-rwxr-xr-xselinux-alpm-hook4
3 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69fc486c2f35..792782c46537 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = selinux-alpm-hook
pkgdesc = SELinux ALPM hook
pkgver = 0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/archlinuxhardened/selinux
arch = any
groups = selinux
license = GPL
- depends = policycoreutils
+ depends = policycoreutils>=3.4
source = relabel-selinux.hook
source = selinux-alpm-hook
sha256sums = 4df844a89a50fe1caebe0cb92fc925b3dedf7a1a8258eef53f0dd328c1cc089e
- sha256sums = c85dbba69b776fbbc5f6886eb3e89406de9237f935a295f7c49d6696ea275187
+ sha256sums = 6786b7ba2dd6887daef304dbbab425b425ddec611d6df943fce27f13ef95def1
pkgname = selinux-alpm-hook
-
diff --git a/PKGBUILD b/PKGBUILD
index d9ca3fcf0ae4..20ce74b5f620 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
pkgname=selinux-alpm-hook
pkgver=0.1
-pkgrel=3
+pkgrel=4
pkgdesc="SELinux ALPM hook"
arch=('any')
url="https://github.com/archlinuxhardened/selinux"
license=('GPL')
groups=('selinux')
-depends=('policycoreutils')
+depends=('policycoreutils>=3.4')
source=('relabel-selinux.hook'
'selinux-alpm-hook')
sha256sums=('4df844a89a50fe1caebe0cb92fc925b3dedf7a1a8258eef53f0dd328c1cc089e'
- 'c85dbba69b776fbbc5f6886eb3e89406de9237f935a295f7c49d6696ea275187')
+ '6786b7ba2dd6887daef304dbbab425b425ddec611d6df943fce27f13ef95def1')
package() {
cd "${srcdir}"
diff --git a/selinux-alpm-hook b/selinux-alpm-hook
index 9ac5b060753f..dd34b3a85e60 100755
--- a/selinux-alpm-hook
+++ b/selinux-alpm-hook
@@ -28,7 +28,7 @@ while read -r FILE; do
# Only show a warning when a file does not exist as this is not fatal
echo >&2 "Ugh, an installed file does not exist: $FILE"
fi
-done | xargs -0 /usr/bin/restorecon -F || die "Error while relabeling files"
+done | xargs -0 /usr/bin/restorecon -F -T0 || die "Error while relabeling files"
# The install hooks of packages create files which got labelled with the wrong SELinux user
# (e.g. sysadm_u instead of system_u). Relabel all these files too.
@@ -83,6 +83,6 @@ GEN_DIRS=(
for DIR in ${GEN_DIRS[@]}; do
# Only relabel directories which exist
if [ -e "$DIR" ]; then
- /usr/bin/restorecon -RF "$DIR" || die "Error while relabeling generated directories"
+ /usr/bin/restorecon -RF -T0 "$DIR" || die "Error while relabeling generated directories"
fi
done