summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD46
-rw-r--r--semaphoreci-cli.install8
4 files changed, 38 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53971103f0bb..893b629186bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = semaphoreci-cli
pkgdesc = Command line tool for the Semaphore CI service
- pkgver = 0.14.1
- pkgrel = 2
+ pkgver = 0.20.0
+ pkgrel = 1
url = https://github.com/semaphoreci/cli
+ install = semaphoreci-cli.install
arch = x86_64
- license = custom:Apache
+ license = Apache
makedepends = go-pie
makedepends = git
- depends = glibc
- source = semaphoreci-cli::git+https://github.com/semaphoreci/cli#tag=v0.14.1
- sha512sums = SKIP
+ source = semaphoreci-cli::git+https://github.com/semaphoreci/cli#tag=v0.20.0
pkgname = semaphoreci-cli
diff --git a/.gitignore b/.gitignore
index 218620e2fb38..dc5ca5acf9c4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!/PKGBUILD
!/.SRCINFO
!/.gitignore
+!/semaphoreci-cli.install
diff --git a/PKGBUILD b/PKGBUILD
index 9bb5308a4fac..b7a4156a1062 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,39 @@
-# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Maintainer: Andy Kluger <https://t.me/andykluger>
+# Contributor: Adrian Perez de Castro <aperez@igalia.com>
pkgdesc='Command line tool for the Semaphore CI service'
pkgname=semaphoreci-cli
-pkgver=0.14.1
-pkgrel=2
+pkgver=0.20.0
+pkgrel=1
url=https://github.com/semaphoreci/cli
-license=(custom:Apache)
+license=(Apache)
arch=(x86_64)
-depends=(glibc)
+depends=()
makedepends=(go-pie git)
source=("${pkgname}::git+${url}#tag=v${pkgver}")
-sha512sums=(SKIP)
+sha512sums=()
+install=semaphoreci-cli.install
build () {
- cd "${pkgname}"
+ cd "${pkgname}"
- local target_arch
- case ${CARCH} in
- x86_64) target_arch=amd64 ;;
- *)
- msg2 "Package not supported on ${CARCH}"
- exit 111
- ;;
- esac
+ local target_arch
+ case ${CARCH} in
+ x86_64) target_arch=amd64 ;;
+ *)
+ msg2 "Package not supported on ${CARCH}"
+ exit 111
+ ;;
+ esac
- GOPATH="${srcdir}/_go" GOOS=linux GOARCH=${target_arch} \
- go build -ldflags "-s -w -X cmd.version=${pkgver}-arch" \
- -o semaphoreci
+ GOPATH="${srcdir}/_go" GOOS=linux GOARCH=${target_arch} \
+ go build -ldflags "-s -w -X cmd.version=${pkgver}-arch" \
+ -o semaphoreci
- chmod -R +w "${srcdir}/_go" # Ugh.
+ chmod -R +w "${srcdir}/_go" # Ugh.
}
package () {
- cd "${pkgname}"
- install -Dm755 -t "${pkgdir}/usr/bin" semaphoreci
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+ cd "${pkgname}"
+ install -Dm755 -t "${pkgdir}/usr/bin" semaphoreci
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}
diff --git a/semaphoreci-cli.install b/semaphoreci-cli.install
new file mode 100644
index 000000000000..a8745f00c7cf
--- /dev/null
+++ b/semaphoreci-cli.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo '>>> The semaphore-cli binary is installed as /bin/semaphoreci,'
+ echo '>>> not /bin/sem, which would conflict with parallel.'
+}
+
+post_upgrade() {
+ post_install $1
+}