aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD57
-rw-r--r--README.md10
4 files changed, 71 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1486f7135d38..50781566ef7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
-# Generated by mksrcinfo v8
-# Wed Aug 24 10:59:20 UTC 2016
pkgbase = senpai
- pkgdesc = UCI compliant open source chess engine by Fabien Letouzey
- pkgver = 1.0
- pkgrel = 1
- url = http://www.chessprogramming.net/senpai/
- arch = i686
+ pkgdesc = TUI IRC Client Created by ~taiite
+ pkgver = 0.2.0
+ pkgrel = 2
+ url = https://sr.ht/~taiite/senpai/
arch = x86_64
- license = GPL
- depends = gcc-libs
- source = senpai.zip::http://maughancdn.s3.amazonaws.com/chess/senpai/1.0/Senpai-1.0.zip
- md5sums = 9ffa2370f8fd7ffd643fc6dc85c99f9e
+ arch = aarch64
+ license = ISC
+ makedepends = go
+ makedepends = scdoc
+ conflicts = senpai-git
+ conflicts = senpai-irc-git
+ replaces = senpai-irc
+ source = senpai-v0.2.0.tar.gz::https://git.sr.ht/~taiite/senpai/archive/v0.2.0.tar.gz
+ sha256sums = 9786fd83f3e1067549c3c88455a1f66ec66d993fe597cee334d217a5d1cf4803
pkgname = senpai
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fad8ee821bcf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# AUR
+src
+pkg
+*.pkg*.zst
+
+# Senpai
+senpai-v*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index f51e8041aa95..472859b1ec74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,47 @@
-# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+# Maintainer: Techcable <$username @ techcable.net>
+# Contributor: Dan Shick <dan.shick@gmail.com>
+# Contributor: Bao Trinh <qubidt at gmail dot com>
+
+# This package is mirored on github at Techcable/aur-senpai
+# PRs and issues welcome
pkgname=senpai
-pkgver=1.0
-pkgrel=1
-pkgdesc="UCI compliant open source chess engine by Fabien Letouzey"
-arch=('i686' 'x86_64')
-url="http://www.chessprogramming.net/senpai/"
-license=('GPL')
-depends=('gcc-libs')
-source=("$pkgname.zip::http://maughancdn.s3.amazonaws.com/chess/senpai/1.0/Senpai-1.0.zip")
-md5sums=('9ffa2370f8fd7ffd643fc6dc85c99f9e')
+pkgver=0.2.0
+pkgrel=2
+pkgdesc='TUI IRC Client Created by ~taiite'
+url=https://sr.ht/~taiite/senpai/
+arch=(x86_64 aarch64)
+license=('ISC')
+# Due to a naming conflict, this package was previously named 'senpai-irc'
+#
+# As of Jun 27, 2023, the other package has been removed.
+# I have renamed the package to be more accurate.
+#
+# The binary continues to be aliased to "senpai-irc" for clarity and compatibility.
+replaces=('senpai-irc')
+conflicts=('senpai-git' 'senpai-irc-git')
+makedepends=('go' 'scdoc')
+source=("senpai-v${pkgver}.tar.gz::https://git.sr.ht/~taiite/senpai/archive/v${pkgver}.tar.gz")
+sha256sums=('9786fd83f3e1067549c3c88455a1f66ec66d993fe597cee334d217a5d1cf4803')
+
+prepare () {
+ cd "${srcdir}/senpai-v${pkgver}"
+ make clean
+}
-build() {
- cd "${srcdir}/Source/"
- g++ -std=c++11 -march=native -pipe -O3 -finline-functions -funroll-all-loops -fno-rtti -lpthread -o senpai senpai_10.cpp
+build () {
+ cd "${srcdir}/senpai-v${pkgver}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ make GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw" all
}
-package() {
- cd "${srcdir}/Source/"
- install -Dm0755 $pkgname ${pkgdir}/usr/bin/$pkgname
+package () {
+ cd "${srcdir}/senpai-v${pkgver}"
+ make "DESTDIR=${pkgdir}" "PREFIX=/usr" install
+ # Alias binary as "senpai-irc" (gives compat with senpai-irc-git)
+ ln -sf "${pkgdir}/usr/bin/senpai" "senpai-irc"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..06b9a0f969f7
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+# senpai-aur
+This is an _unofficial_ AUR package for the [senpai IRC client](https://sr.ht/~taiite/senpai/).
+
+It is in no way endorsed by upstream, so make sure you can distinguish between their bugs and ours ;)
+
+The AUR package used to be named `senpai-irc` due to conflict with an existing `senpai` package. As of Jun 27, 2023, the other package has been deleted. So this package has been renamed to `senpai` for clarity.
+
+The package has been mirrored to Github.
+
+PRs and issues are welcome.