aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1f38c9cbcbb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Wed Mar 9 18:20:44 UTC 2016
+pkgbase = senpai
+ pkgdesc = UCI compliant open source chess engine by Fabien Letouzey
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.chessprogramming.net/senpai/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ provides = senpai=1.0
+ conflicts = senpai-git
+ options = !emptydirs
+ source = senpai.zip::http://maughancdn.s3.amazonaws.com/chess/senpai/1.0/Senpai-1.0.zip
+ md5sums = 9ffa2370f8fd7ffd643fc6dc85c99f9e
+
+pkgname = senpai
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b23115c1dd9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer : Özgür Sarıer <echo b3pndXJzYXJpZXIxMDExNjAxMTE1QGdtYWlsLmNvbQo= | base64 -d>
+
+pkgname=senpai
+pkgver=1.0
+pkgrel=1
+pkgdesc="UCI compliant open source chess engine by Fabien Letouzey"
+arch=('i686' 'x86_64')
+url="http://www.chessprogramming.net/senpai/"
+license=('GPL')
+conflicts=("$pkgname-git")
+provides=("$pkgname=$pkgver")
+options=(!emptydirs)
+source=("$pkgname.zip::http://maughancdn.s3.amazonaws.com/chess/senpai/1.0/Senpai-1.0.zip")
+md5sums=('9ffa2370f8fd7ffd643fc6dc85c99f9e')
+
+build() {
+ cd "${srcdir}/Source/"
+ g++ -std=c++11 -march=native -pipe -O3 -finline-functions -funroll-all-loops -fno-rtti -lpthread -o senpai senpai_10.cpp
+}
+
+package() {
+ cd "${srcdir}/Source/"
+ install -Dm0755 $pkgname ${pkgdir}/usr/bin/$pkgname
+}