summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec97d4c3d24a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sets
+ pkgdesc = The practical way to do set operations on sets of lines in the shell
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/maandree/sets
+ arch = any
+ license = AGPL3
+ depends = python>=3
+ provides = sets
+ conflicts = sets
+ source = https://github.com/maandree/sets/archive/1.3.tar.gz
+ sha256sums = 3f0f7fa0918991530f51f1c5d066e662a4e19169eda14295d6f3ff261c70bcce
+
+pkgname = sets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de17caf7e3d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+pkgname=sets
+pkgver=1.3
+pkgrel=1
+pkgdesc="The practical way to do set operations on sets of lines in the shell"
+arch=('any')
+url="https://github.com/maandree/sets"
+license=('AGPL3')
+depends=('python>=3')
+provides=($pkgname)
+conflicts=($pkgname)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(3f0f7fa0918991530f51f1c5d066e662a4e19169eda14295d6f3ff261c70bcce)
+
+build() {
+ cd sets-$pkgver
+ make DESTDIR="$pkgdir/"
+}
+
+package() {
+ cd sets-$pkgver
+ make DESTDIR="$pkgdir/" install
+}