summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD21
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f87f5d53ed0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = sfml-bin
+ pkgdesc = The Simple and Fast Multimedia Library
+ pkgver = 2.5.1
+ pkgrel = 1
+ url = https://www.sfml-dev.org/
+ arch = x86_64
+ license = custom
+ depends = flac
+ depends = freetype2
+ depends = graphite
+ depends = libglvnd
+ depends = libvorbis
+ depends = libxrandr
+ depends = openal
+ depends = pcre
+ provides = sfml=2.5.1
+ conflicts = sfml
+ source = https://www.sfml-dev.org/files/SFML-2.5.1-linux-gcc-64-bit.tar.gz
+ source = LICENSE
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = sfml-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..36fef8c4c812
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+SFML (Simple and Fast Multimedia Library) - Copyright (c) Laurent Gomila
+
+This software is provided 'as-is', without any express or implied warranty.
+In no event will the authors be held liable for any damages arising from
+the use of this software.
+
+Permission is granted to anyone to use this software for any purpose,
+including commercial applications, and to alter it and redistribute it
+freely, subject to the following restrictions:
+
+1. The origin of this software must not be misrepresented; you must not claim
+ that you wrote the original software. If you use this software in a product,
+ an acknowledgment in the product documentation would be appreciated but is
+ not required.
+
+2. Altered source versions must be plainly marked as such, and must not be
+ misrepresented as being the original software.
+
+3. This notice may not be removed or altered from any source distribution.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..317e0f5366e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Jaden Peterson <jadenpeterson150@gmail.com>
+
+pkgname=sfml-bin
+pkgver=2.5.1
+pkgrel=1
+pkgdesc='The Simple and Fast Multimedia Library'
+arch=('x86_64')
+url='https://www.sfml-dev.org/'
+license=('custom')
+depends=('flac' 'freetype2' 'graphite' 'libglvnd' 'libvorbis' 'libxrandr' 'openal' 'pcre')
+
+provides=("sfml=${pkgver}")
+conflicts=('sfml')
+
+source=("https://www.sfml-dev.org/files/SFML-${pkgver}-linux-gcc-64-bit.tar.gz" 'LICENSE')
+sha256sums=('SKIP' 'SKIP')
+
+package() {
+ cp -r "SFML-${pkgver}" "${pkgdir}/usr"
+ install -Dm644 'LICENSE' "${pkgdir}/usr/share/licenses/sfml/LICENSE"
+}