summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--sftpgo.json4
3 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e04e8d404dd..f08965d12136 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sftpgo-bin
- pkgdesc = Full featured and highly configurable SFTP server
+ pkgdesc = Fully featured and highly configurable SFTP server
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/drakkan/sftpgo
arch = x86_64
license = GPL3
@@ -18,7 +18,7 @@ pkgbase = sftpgo-bin
source = https://github.com/drakkan/sftpgo/releases/download/v1.0.0/sftpgo_v1.0.0_linux_x86_64.tar.xz
source = sftpgo.json
sha256sums = 25d7d84e6a97d2cb70891ab542ed92eb6991291c029075513e3fd3e187f6a55c
- sha256sums = d4bc2ddb3104e2e1be40103e7653f2d7802658576ba8e80bebfad7901a8b46a4
+ sha256sums = fb4dc558c4dcba5e9d9ce9716653439b11d34f468599609cc4b8e79692ef8417
pkgname = sftpgo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 029528d98738..1d867617ed90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=sftpgo-bin
_pkgname=sftpgo
pkgver=1.0.0
-pkgrel=1
-pkgdesc='Full featured and highly configurable SFTP server'
+pkgrel=2
+pkgdesc='Fully featured and highly configurable SFTP server'
arch=('x86_64')
url="https://github.com/drakkan/${_pkgname}"
license=('GPL3')
@@ -26,7 +26,7 @@ backup=(
source=("https://github.com/drakkan/sftpgo/releases/download/v${pkgver}/sftpgo_v${pkgver}_linux_x86_64.tar.xz"
"sftpgo.json")
sha256sums=('25d7d84e6a97d2cb70891ab542ed92eb6991291c029075513e3fd3e187f6a55c'
- 'd4bc2ddb3104e2e1be40103e7653f2d7802658576ba8e80bebfad7901a8b46a4')
+ 'fb4dc558c4dcba5e9d9ce9716653439b11d34f468599609cc4b8e79692ef8417')
package() {
install -Dm 755 sftpgo "$pkgdir/usr/bin/${_pkgname}"
@@ -35,9 +35,11 @@ package() {
install -Dm 644 "$srcdir/sftpgo.json" -t "${pkgdir}/etc/${_pkgname}"
install -d "${pkgdir}/var/lib/${_pkgname}"
install -Dm 644 sqlite/sftpgo.db -t "${pkgdir}/var/lib/${_pkgname}"
- cp -r templates "${pkgdir}/var/lib/${_pkgname}/"
- cp -r static "${pkgdir}/var/lib/${_pkgname}/"
+ install -d "${pkgdir}/usr/share/${_pkgname}"
+ cp -r templates "${pkgdir}/usr/share/${_pkgname}/"
+ cp -r static "${pkgdir}/usr/share/${_pkgname}/"
install -d "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -Dm 644 "$srcdir/sftpgo.json" "${pkgdir}/usr/share/doc/${_pkgname}/sftpgo.json.default"
install -Dm 644 README.txt "${pkgdir}"/usr/share/doc/${_pkgname}/README
install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${_pkgname}/LICENSE
}
diff --git a/sftpgo.json b/sftpgo.json
index 44369fd86074..1b8679cb6f71 100644
--- a/sftpgo.json
+++ b/sftpgo.json
@@ -55,8 +55,8 @@
"httpd": {
"bind_port": 8080,
"bind_address": "127.0.0.1",
- "templates_path": "/var/lib/sftpgo/templates",
- "static_files_path": "/var/lib/sftpgo/static",
+ "templates_path": "/usr/share/sftpgo/templates",
+ "static_files_path": "/usr/share/sftpgo/static",
"backups_path": "/var/lib/sftpgo/backups",
"auth_user_file": "",
"certificate_file": "",