aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98cf6ebc6108..dd9f2a598bb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = sftpgo-git
pkgdesc = Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP
- pkgver = r850.969c992
+ pkgver = r865.9dcaf15
pkgrel = 1
url = https://github.com/drakkan/sftpgo
install = sftpgo-git.install
arch = i686
arch = x86_64
arch = aarch64
- license = GPL3
+ license = AGPLv3
makedepends = gcc
makedepends = git
makedepends = go
diff --git a/PKGBUILD b/PKGBUILD
index e92e168eb5f1..a72866915c7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: drakkan <nicola.murino at gmail dot com>
pkgname=sftpgo-git
_pkgname=sftpgo
-pkgver=r850.969c992
+pkgver=r865.9dcaf15
pkgrel=1
pkgdesc='Fully featured and highly configurable SFTP server with optional FTP/S and WebDAV support. It can serve local filesystem, S3, GCS, Azure Blob, SFTP'
arch=('i686' 'x86_64' 'aarch64')
url="https://github.com/drakkan/${_pkgname}"
-license=('GPL3')
+license=('AGPLv3')
depends=('glibc')
makedepends=('gcc' 'git' 'go' 'gzip')
optdepends=(
@@ -38,7 +38,7 @@ pkgver() {
build() {
cd "${_pkgname}"
- go build -ldflags "-s -w -X github.com/drakkan/sftpgo/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/version.date=`date --utc +%FT%TZ`" -v -o sftpgo
+ go build -trimpath -ldflags "-s -w -X github.com/drakkan/sftpgo/version.commit=`git describe --always --dirty` -X github.com/drakkan/sftpgo/version.date=`date --utc +%FT%TZ`" -v -o sftpgo
./sftpgo gen completion bash > sftpgo-completion.bash
./sftpgo gen man -d man1
gzip man1/*