summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--configure-rpath.patch34
4 files changed, 108 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..43603e276612
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = sga
+ pkgdesc = de novo sequence assembler using string graphs
+ pkgver = 0.10.13
+ pkgrel = 1
+ url = https://github.com/jts/sga
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = sparsehash
+ depends = bamtools
+ depends = jemalloc
+ depends = python
+ source = sga-0.10.13.tar.gz::https://github.com/jts/sga/archive/v0.10.13.tar.gz
+ source = configure-rpath.patch
+ md5sums = d4f6aefc48c940dba96cc6513649ecdd
+ md5sums = SKIP
+
+pkgname = sga
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43603e276612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = sga
+ pkgdesc = de novo sequence assembler using string graphs
+ pkgver = 0.10.13
+ pkgrel = 1
+ url = https://github.com/jts/sga
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = sparsehash
+ depends = bamtools
+ depends = jemalloc
+ depends = python
+ source = sga-0.10.13.tar.gz::https://github.com/jts/sga/archive/v0.10.13.tar.gz
+ source = configure-rpath.patch
+ md5sums = d4f6aefc48c940dba96cc6513649ecdd
+ md5sums = SKIP
+
+pkgname = sga
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f879c950fecc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=sga
+pkgver=0.10.13
+pkgrel=1
+pkgdesc="de novo sequence assembler using string graphs"
+arch=('x86_64' 'i686')
+url="https://github.com/jts/sga"
+license=('GPL3')
+depends=('bamtools' 'jemalloc' 'python')
+makedepends=('sparsehash')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jts/sga/archive/v$pkgver.tar.gz"
+ 'configure-rpath.patch')
+md5sums=('d4f6aefc48c940dba96cc6513649ecdd'
+ 'SKIP')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver/src
+
+ patch -p0 -i $srcdir/configure-rpath.patch
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver/src
+
+ ./autogen.sh
+ ./configure --prefix=/usr --with-bamtools=/usr --with-jemalloc=/usr
+
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver/src
+
+ make DESTDIR=$pkgdir install
+}
diff --git a/configure-rpath.patch b/configure-rpath.patch
new file mode 100644
index 000000000000..2ec981c5fb14
--- /dev/null
+++ b/configure-rpath.patch
@@ -0,0 +1,34 @@
+--- configure.ac 2014-01-17 21:16:36.000000000 +0100
++++ /tmp/configure.ac.patched 2014-11-07 14:04:25.882803929 +0100
+@@ -32,8 +32,8 @@
+ [specify directory containing the bamtools library (http://github.com/pezmaster31/bamtools)]))
+
+ if test "$with_bamtools" -a -d "$with_bamtools"; then
+- bamtools_ldflags="-Wl,-rpath,$with_bamtools/lib -L$with_bamtools/lib -Wl,-rpath,$with_bamtools/lib/bamtools -L$with_bamtools/lib/bamtools"
+- bamtools_include="-I$with_bamtools/include -I$with_bamtools/include/bamtools"
++ bamtools_ldflags=""
++ bamtools_include="-I$with_bamtools/include/bamtools"
+ fi
+
+ # Support for tcmalloc/jemalloc/hoard
+@@ -52,17 +52,17 @@
+
+ # Set library path to user-selected allocator
+ if test "$with_hoard" -a -d "$with_hoard"; then
+- external_malloc_ldflags="-Wl,-rpath,$with_hoard -L$with_hoard"
++ external_malloc_ldflags=""
+ enable_hoard=1
+ fi
+
+ if test "$with_tcmalloc" -a -d "$with_tcmalloc"; then
+- external_malloc_ldflags="-Wl,-rpath,$with_tcmalloc -L$with_tcmalloc"
++ external_malloc_ldflags=""
+ enable_tcmalloc=1
+ fi
+
+ if test "$with_jemalloc" -a -d "$with_jemalloc"; then
+- external_malloc_ldflags="-Wl,-rpath,$with_jemalloc -L$with_jemalloc"
++ external_malloc_ldflags=""
+ enable_jemalloc=1
+ fi
+