summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04d397790fc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sgfutils
+ pkgdesc = Collection of command line utilities that help working with SGF files
+ pkgver = 0.25
+ pkgrel = 1
+ url = https://homepages.cwi.nl/~aeb/go/sgfutils/
+ arch = x86_64
+ license = GPL
+ depends = openssl
+ source = https://homepages.cwi.nl/~aeb/go/sgfutils/sgfutils-0.25.tgz
+ sha256sums = 4b26b321fbe255722f1d7e57233614da89a4da5bab031ae4ef7118ae3c7436a2
+
+pkgname = sgfutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10bbacd34b1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=sgfutils
+pkgver=0.25
+pkgrel=1
+pkgdesc='Collection of command line utilities that help working with SGF files'
+url='https://homepages.cwi.nl/~aeb/go/sgfutils/'
+license=('GPL')
+arch=('x86_64')
+depends=('openssl')
+source=("${url}${pkgname}-${pkgver}.tgz")
+sha256sums=('4b26b321fbe255722f1d7e57233614da89a4da5bab031ae4ef7118ae3c7436a2')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed 's/^CFLAGS=/CFLAGS+=/' -i Makefile
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ls | while read i; do
+ if [[ ! -d "$i" && -x "$i" ]]; then
+ install -D "$i" "${pkgdir}/usr/bin/$i"
+ fi
+ done
+
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -a html/* "${pkgdir}/usr/share/doc/${pkgname}"
+}