summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 396b85398125..581fe6daece2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = sgopherd-git
pkgdesc = A gopher server written in Bash
- pkgver = 20111105
+ pkgver = 20121007
pkgrel = 1
url = https://github.com/vain/sgopherd
arch = any
license = custom:PIZZA-WARE
makedepends = git
depends = bash
- depends = xinetd
+ optdepends = xinetd: Traditional way to run sgopherd
+ optdepends = systemd: sgopherd also works with socket activation
backup = etc/xinetd.d/sgopherd
pkgname = sgopherd-git
diff --git a/PKGBUILD b/PKGBUILD
index 8db8c0ed524d..4bbc5c5cce95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Vain <aurmaint1 on host: uninformativ dot de>
pkgname=sgopherd-git
-pkgver=20111105
+pkgver=20121007
pkgrel=1
pkgdesc="A gopher server written in Bash"
arch=('any')
url="https://github.com/vain/sgopherd"
license=('custom:PIZZA-WARE')
-depends=('bash' 'xinetd')
+depends=('bash')
makedepends=('git')
backup=('etc/xinetd.d/sgopherd')
+optdepends=('xinetd: Traditional way to run sgopherd'
+ 'systemd: sgopherd also works with socket activation')
_gitroot="git://github.com/vain/sgopherd.git"
_gitname="master"
@@ -34,8 +36,18 @@ build() {
package() {
cd "$srcdir/$_gitname-build"
+
install -Dm755 sgopherd "$pkgdir"/usr/bin/sgopherd
- install -Dm644 xinetd-example.conf "$pkgdir"/etc/xinetd.d/sgopherd
+
+ install -Dm644 xinetd/xinetd-example.conf "$pkgdir"/etc/xinetd.d/sgopherd
+
+ install -Dm644 systemd/sgopherd@.service \
+ "$pkgdir"/usr/lib/systemd/system/sgopherd@.service
+ install -Dm644 systemd/sgopherd.socket \
+ "$pkgdir"/usr/lib/systemd/system/sgopherd.socket
+ install -Dm755 systemd/sgopherd-systemd \
+ "$pkgdir"/usr/bin/sgopherd-systemd
+
install -Dm644 man8/sgopherd.8 "$pkgdir"/usr/share/man/man8/sgopherd.8
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}