aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--Makefile10
-rw-r--r--PKGBUILD28
-rw-r--r--README.md9
-rw-r--r--shadow-beta.install26
5 files changed, 41 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d8403e57b6f..f8bdb30af17d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shadow-beta
pkgdesc = Shadow launcher
- pkgver = 4.2.7
- pkgrel = 1
+ pkgver = 0.8.62
+ pkgrel = 3
url = http://shadow.tech
install = shadow-beta.install
arch = x86_64
@@ -30,10 +30,15 @@ pkgbase = shadow-beta
depends = gcc7-libs
depends = ttf-dejavu
depends = libxss
- depends = libsndio-61-compat
provides = shadow-beta
- source = https://shadow.tech/linux/shadow-beta.zip
- md5sums = 8e56c7d8f0940e3854b898914d7cda7b
+ source = https://macosx.update.blade-group.fr/mpl/linux/beta/bionic/shadow-alpha-bionic.zip
+ source = https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/084a22e1de394060b60a621db790f87062e9544a/AppImage/wrapper.pl
+ source = https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/084a22e1de394060b60a621db790f87062e9544a/AppImage/report.pl
+ source = https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/084a22e1de394060b60a621db790f87062e9544a/shadow-beta.desktop
+ md5sums = bb5adca354d043b10bc5aca0a5afb37a
+ md5sums = acc9366ee43a7f4300969009b688bb0c
+ md5sums = 65b5ab84660ceddac9068765243ba432
+ md5sums = f933f6568441e1a211c836c235e572f4
pkgname = shadow-beta
diff --git a/Makefile b/Makefile
index eef401b24b13..4a30a06cfe22 100644
--- a/Makefile
+++ b/Makefile
@@ -1,19 +1,15 @@
-version = 9add3366d25530d51d168608c54b5339b64d2a4e
-
-help:
+help:
@grep -E '(^[a-zA-Z_-]+:.*?##.*$$)|(^##)' $(MAKEFILE_LIST) | awk 'BEGIN {FS = ":.*?## "}; {printf "\033[32m%-10s\033[0m %s\n", $$1, $$2}' | sed -e 's/\[32m##/[33m/'
-build:clear recup ## Build pakage
+build:clear ## Build pakage
makepkg -s
clear: ## Clear files
rm -rf ./pkg
rm -rf ./src
- rm -f ./*.deb
+ rm -f ./shadowbeta.deb
rm -f ./shadow-beta-*.pkg.tar
- rm -f ./shadow-beta-*.pkg.tar.xz
rm -f ./*~
- rm -f shadow-beta.zip
install:build ## Install package with pacman
sudo pacman -U shadow-beta-*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
index 6d936eb949a3..80c23d410222 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Made with https://github.com/NicolasGuilloux/blade-shadow-beta
_commit=9add3366d25530d51d168608c54b5339b64d2a4e
pkgname=shadow-beta
-pkgver=4.2.7
+pkgver=4.3.1
pkgrel=1
pkgdesc="Shadow launcher"
arch=('x86_64')
@@ -14,17 +14,18 @@ url="http://shadow.tech"
license=('unknown')
depends=('desktop-file-utils' 'freetype2' 'libuv' 'gconf' 'hicolor-icon-theme' 'json-c' 'libappindicator-gtk2' 'libbsd' 'libcurl-gnutls' 'libdrm' 'libnotify' 'libva' 'libxtst' 'nss' 'opus' 'qt5-base' 'qt5-svg' 'sdl2' 'libappindicator' 'libcurl-compat' 'sdl' 'gcc7-libs' 'ttf-dejavu' 'libxss' 'libsndio-61-compat')
provides=(shadow-beta)
-source=('https://shadow.tech/linux/shadow-beta.zip')
-md5sums=('8e56c7d8f0940e3854b898914d7cda7b')
+source=('https://update.shadow.tech/launcher/preprod/linux/ubuntu_18.04/ShadowBeta.zip')
+md5sums=('5f31366f35fbdee9b56ad4c56ebcbe5f')
install=$pkgname.install
# Build the package
package() {
- ### Create working folder
- mkdir shadow
- ### Extract zip file
- bsdtar -x -f shadow-beta.zip -C shadow
+ ### Create working folder
+ mkdir shadow
+
+ ### Extract zip file
+ bsdtar -x -f ShadowBeta.zip -C shadow
### Extract the deb
ar xv shadow/Shadow*.deb
@@ -32,16 +33,21 @@ package() {
### Extract the data
bsdtar xf data.tar.xz
+ mv "${srcdir}/usr/share/icons/hicolor/0x0/" "${srcdir}/usr/share/icons/hicolor/1024x1024/"
+ mv "${srcdir}/usr/share/icons/hicolor/1024x1024/apps/shadow-preprod.png" "${srcdir}/usr/share/icons/shadow-beta.png"
+
chmod -R g-w usr
mv usr "${pkgdir}"
chmod -R g-w opt
mv opt "${pkgdir}"
- # Move to shortcut directory
- cd "${pkgdir}/usr/share/applications/"
- sed -e 's/^Categories=.*$/Categories=Games;Game;Utility;Virtualization/g' shadow*.desktop > "$srcdir/shadow-beta.desktop"
- rm shadow*.desktop
+ # Move to shortcut directory
+ cd "${pkgdir}/usr/share/applications/"
+
+ sed -i -e 's/^Categories=.*$/Categories=Games;Game;Utility;Virtualization/g' shadow-preprod.desktop
+ sed -i -e 's/^Icon=.*$/Icon=shadow-beta.png/g' shadow-preprod.desktop
+ mv shadow-preprod.desktop "$srcdir/shadow-beta.desktop"
# Move the source directory
cd "$srcdir"
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..2772061e2558
--- /dev/null
+++ b/README.md
@@ -0,0 +1,9 @@
+# Custom PKBUILD
+
+This PKBUILD and INSTALL file creates a package for Arch Linux distribution compatible with the pacman package manager.
+
+This work is a support for the AUR package made by agentcobra#6142.
+
+To use it, download the files and go in this directory. Then, do a `makepkg` to build the package and finally, do `sudo pacman -U ./shadow-beta-*-x86_64.pkg.tar.xz` to install it.
+
+It is an all-in-one installer as in embbeds a wrapper that check your configuration (the same used in the AppImage) and fix all the bugs on Arch Linux. The only thing left for Arch users is to setup a valid VA-API installation.
diff --git a/shadow-beta.install b/shadow-beta.install
index af98596a8ac0..cf06b09fe7d0 100644
--- a/shadow-beta.install
+++ b/shadow-beta.install
@@ -6,7 +6,7 @@ post_install() {
done
# Create the link to the binary
- ln -sf '/opt/Shadow Beta/shadow-dev' '/usr/bin/shadow-beta'
+ ln -sf '/opt/shadowbeta/shadow-wrapper.pl' '/usr/bin/shadow-beta'
}
post_remove() {
@@ -16,22 +16,6 @@ post_remove() {
if [ -d /home/$user/.config/Shadow\ Beta ]; then
rm -R /home/$user/.config/Shadow\ Beta
fi
-
- if [ -d /home/$user/.config/shadow-beta ]; then
- rm -R /home/$user/.config/shadow-beta
- fi
-
- if [ -d /home/$user/.config/shadowbeta ]; then
- rm -R /home/$user/.config/shadowbeta
- fi
-
- if [ -d /home/$user/.config/shadow-preprod ]; then
- rm -R /home/$user/.config/shadow-preprod
- fi
-
- if [ -d /home/$user/.config/shadow-dev ]; then
- rm -R /home/$user/.config/shadow-dev
- fi
done
}
@@ -40,14 +24,8 @@ pre_upgrade(){
if [ -d "/opt/Shadow Beta" ]; then
rm -r "/opt/Shadow Beta"
fi
-
- # Delete the old version of Shadow
- if [ -d "/opt/shadowbeta" ]; then
- rm -r "/opt/shadowbeta"
- fi
}
post_upgrade(){
- # Replace current shortcut with the new one
- ln -sf '/opt/Shadow Beta/shadow-dev' '/usr/bin/shadow-beta'
+ post_install
}