summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03d9b870e745..7bd41fab09cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shadow-selinux
pkgdesc = Password and account management tool suite with support for shadow files and PAM - SELinux support
- pkgver = 4.8.1
- pkgrel = 5
+ pkgver = 4.11.1
+ pkgrel = 1
url = https://github.com/shadow-maint/shadow
install = shadow.install
arch = x86_64
@@ -18,11 +18,11 @@ pkgbase = shadow-selinux
depends = libxcrypt
depends = libcrypt.so
depends = libsemanage>=3.2
- provides = shadow=4.8.1-5
- provides = selinux-shadow=4.8.1-5
+ provides = shadow=4.11.1-1
+ provides = selinux-shadow=4.11.1-1
conflicts = shadow
conflicts = selinux-shadow
- options = strip
+ options = !emptydirs
backup = etc/login.defs
backup = etc/pam.d/chage
backup = etc/pam.d/passwd
@@ -38,8 +38,8 @@ pkgbase = shadow-selinux
backup = etc/pam.d/chgpasswd
backup = etc/pam.d/groupmems
backup = etc/default/useradd
- source = https://github.com/shadow-maint/shadow/releases/download/4.8.1/shadow-4.8.1.tar.xz
- source = https://github.com/shadow-maint/shadow/releases/download/4.8.1/shadow-4.8.1.tar.xz.asc
+ source = https://github.com/shadow-maint/shadow/releases/download/v4.11.1/shadow-4.11.1.tar.xz
+ source = https://github.com/shadow-maint/shadow/releases/download/v4.11.1/shadow-4.11.1.tar.xz.asc
source = LICENSE
source = chgpasswd
source = chpasswd
@@ -50,9 +50,8 @@ pkgbase = shadow-selinux
source = shadow.timer
source = shadow.service
source = useradd.defaults
- validpgpkeys = D5C2F9BFCA128BBA22A77218872F702C4D6E25A8
- validpgpkeys = F1D08DB778185BF784002DFFE9FEEA06A85E3F9D
- sha1sums = 63457a0ba58dc4e81b2663b839dc6c89d3343f12
+ validpgpkeys = 66D0387DB85D320F8408166DB175CFA98F192AF2
+ sha1sums = 9cb767b86ff2b46e880b428e817972aa07b3a67c
sha1sums = SKIP
sha1sums = 33a6cf1e44a1410e5c9726c89e5de68b78f5f922
sha1sums = 4ad0e059406a305c8640ed30d93c2a1f62c2f4ad
diff --git a/PKGBUILD b/PKGBUILD
index 1e904c9dd120..785e56635a3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=shadow-selinux
-pkgver=4.8.1
-pkgrel=5
+pkgver=4.11.1
+pkgrel=1
pkgdesc="Password and account management tool suite with support for shadow files and PAM - SELinux support"
arch=('x86_64' 'aarch64')
url='https://github.com/shadow-maint/shadow'
@@ -27,10 +27,9 @@ backup=(etc/login.defs
etc/pam.d/{chpasswd,newusers,groupadd,groupdel,groupmod}
etc/pam.d/{chgpasswd,groupmems}
etc/default/useradd)
-options=(strip)
-validpgpkeys=('D5C2F9BFCA128BBA22A77218872F702C4D6E25A8' # Christian Perrier
- 'F1D08DB778185BF784002DFFE9FEEA06A85E3F9D') # Serge Hallyn
-source=("https://github.com/shadow-maint/shadow/releases/download/$pkgver/shadow-$pkgver.tar.xz"{,.asc}
+options=('!emptydirs')
+validpgpkeys=('66D0387DB85D320F8408166DB175CFA98F192AF2') # Serge Hallyn
+source=("https://github.com/shadow-maint/shadow/releases/download/v$pkgver/shadow-$pkgver.tar.xz"{,.asc}
LICENSE
chgpasswd
chpasswd
@@ -41,7 +40,7 @@ source=("https://github.com/shadow-maint/shadow/releases/download/$pkgver/shadow
shadow.{timer,service}
useradd.defaults)
install=shadow.install
-sha1sums=('63457a0ba58dc4e81b2663b839dc6c89d3343f12'
+sha1sums=('9cb767b86ff2b46e880b428e817972aa07b3a67c'
'SKIP'
'33a6cf1e44a1410e5c9726c89e5de68b78f5f922'
'4ad0e059406a305c8640ed30d93c2a1f62c2f4ad'
@@ -57,7 +56,6 @@ sha1sums=('63457a0ba58dc4e81b2663b839dc6c89d3343f12'
build() {
cd "${pkgname/-selinux}-$pkgver"
- autoreconf -fsiv
./configure \
--prefix=/usr \
--bindir=/usr/bin \
@@ -69,7 +67,8 @@ build() {
--with-libpam \
--with-group-name-max-length=32 \
--with-audit \
- --with-selinux
+ --with-selinux \
+ --without-su
make
}
@@ -78,6 +77,7 @@ package() {
cd "${pkgname/-selinux}-$pkgver"
make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" -C man install
# license
install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
@@ -112,7 +112,7 @@ package() {
# Remove utilities provided by util-linux
rm \
- "$pkgdir"/usr/bin/{login,su,chsh,chfn,sg,nologin} \
+ "$pkgdir"/usr/bin/{login,chsh,chfn,sg,nologin} \
"$pkgdir"/usr/sbin/{vipw,vigr}
# but we keep newgrp, as sg is really an alias to it
@@ -130,9 +130,6 @@ package() {
-name 'vigr.8' -o \
-name 'newgrp.1' ')' \
-delete
- rmdir \
- "$pkgdir"/usr/share/man/{fi,id,zh_TW}/man1 \
- "$pkgdir"/usr/share/man/{fi,ko/man8}
# move everything else to /usr/bin, because this isn't handled by ./configure
mv "$pkgdir"/usr/sbin/* "$pkgdir"/usr/bin