summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c91bcf58c2bc..c425a20f32c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = shantz-xwinwrap-bzr
pkgdesc = Utility to play Movies on your Desktop Or ElectricSheep
pkgver = 20090421
- pkgrel = 4
+ pkgrel = 5
url = https://shantanugoel.com/2008/09/03/shantz-xwinwrap/
arch = i686
arch = x86_64
- license = Other/Open
- license = Source
+ license = MIT
makedepends = bzr
- makedepends = make
makedepends = python-dulwich
depends = libxext
depends = libxrender
provides = xwinwrap
conflicts = xwinwrap
+ source = LICENSE
+ sha512sums = SKIP
pkgname = shantz-xwinwrap-bzr
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1d2fb03d34ab
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+/*
+ * Copyright © 2005 Novell, Inc.
+ *
+ * Permission to use, copy, modify, distribute, and sell this software
+ * and its documentation for any purpose is hereby granted without
+ * fee, provided that the above copyright notice appear in all copies
+ * and that both that copyright notice and this permission notice
+ * appear in supporting documentation, and that the name of
+ * Novell, Inc. not be used in advertising or publicity pertaining to
+ * distribution of the software without specific, written prior permission.
+ * Novell, Inc. makes no representations about the suitability of this
+ * software for any purpose. It is provided "as is" without express or
+ * implied warranty.
+ *
+ * NOVELL, INC. DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+ * INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+ * NO EVENT SHALL NOVELL, INC. BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+ * CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+ * OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+ * NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION
+ * WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ * Author: David Reveman <davidr@novell.com>
+ */
diff --git a/PKGBUILD b/PKGBUILD
index 80412684769e..18be5e1bcf3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,19 @@
pkgname=shantz-xwinwrap-bzr
pkgver=20090421
-pkgrel=4
+pkgrel=5
pkgdesc="Utility to play Movies on your Desktop Or ElectricSheep"
[ "$CARCH" = "i686" ] && ARCH=x86
[ "$CARCH" = "x86_64" ] && ARCH=x86_64
arch=(i686 x86_64)
url="https://shantanugoel.com/2008/09/03/shantz-xwinwrap/"
-license=(Other/Open Source)
+license=(MIT)
depends=(libxext libxrender)
provides=('xwinwrap')
conflicts=('xwinwrap')
-makedepends=('bzr' 'make' 'python-dulwich')
-
-source=()
-md5sums=()
+makedepends=('bzr' 'python-dulwich')
+source=('LICENSE')
+sha512sums=('SKIP')
_bzrroot="lp:xwinwrap"
_bzrmod="xwinwrap"
@@ -29,16 +28,17 @@ build() {
bzr branch $_bzrroot
cd $_bzrmod
if [ "$CARCH" == "i686" ]; then
- make all32 || return 1
+ make all32
else
- make all64 || return 1
+ make all64
fi
}
package() {
- cd $_bzrmod
+ cd ${srcdir}
if [ "$CARCH" == "i686" ]; then
- install -D -m0755 ${srcdir}/xwinwrap/i386/xwinwrap ${pkgdir}/usr/bin/xwinwrap || return 1
+ install -D -m0755 xwinwrap/i386/xwinwrap ${pkgdir}/usr/bin/xwinwrap
else
- install -D -m0755 ${srcdir}/xwinwrap/x86_64/xwinwrap ${pkgdir}/usr/bin/xwinwrap || return 1
+ install -D -m0755 xwinwrap/x86_64/xwinwrap ${pkgdir}/usr/bin/xwinwrap
fi
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}