summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD9
-rw-r--r--sheepit-client.conf38
-rw-r--r--sheepit-client.install6
-rw-r--r--sheepit-client.service4
5 files changed, 50 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c51dc016995..2ca57e7776ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun May 29 19:14:12 UTC 2016
+# Sun Apr 30 07:51:48 UTC 2017
pkgbase = sheepit-client-git
pkgdesc = Client for the free and distributed render farm
- pkgver = 3.3.2r200.358ec13
- pkgrel = 2
+ pkgver = 5.0.0r270.e2616a8
+ pkgrel = 1
url = https://www.sheepit-renderfarm.com/
install = sheepit-client.install
arch = i686
@@ -14,6 +14,8 @@ pkgbase = sheepit-client-git
depends = java-runtime
depends = freetype2
depends = glew
+ optdepends = cuda: CUDA GPU rendering (not in service mode)
+ optdepends = blender: Create 3D scenes to render
provides = sheepit-client
conflicts = sheepit-client
backup = etc/conf.d/sheepit-client
@@ -25,8 +27,8 @@ pkgbase = sheepit-client-git
md5sums = SKIP
md5sums = a30b3ba1c40b2063ccab54b65a7b8e09
md5sums = ade86db2b906f3468e014b28ebdd36d6
- md5sums = 7ffbac5dffd3ffcf04ffba3c0c1f5bd2
- md5sums = 9ee9b4ddbac31567f63520beb4d5628f
+ md5sums = 30e9d9e679a8b22d9c5efbf64c14743c
+ md5sums = e051e06111c73777914dffee61b43afc
pkgname = sheepit-client-git
diff --git a/PKGBUILD b/PKGBUILD
index 68affe489d19..3b50c00b49e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Geoffrey Frogeye <geoffrey@frogeye.fr>
pkgname=sheepit-client-git
-pkgver=3.3.2r200.358ec13
-pkgrel=2
+pkgver=5.0.0r270.e2616a8
+pkgrel=1
pkgdesc="Client for the free and distributed render farm"
arch=('i686' 'x86_64')
url="https://www.sheepit-renderfarm.com/"
license=('GPL')
depends=('java-runtime' 'freetype2' 'glew')
makedepends=('git' 'apache-ant')
+optdepends=('cuda: CUDA GPU rendering (not in service mode)' 'blender: Create 3D scenes to render')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
install=sheepit-client.install
@@ -21,8 +22,8 @@ source=('git://github.com/laurent-clouet/sheepit-client.git#branch=master'
md5sums=('SKIP'
'a30b3ba1c40b2063ccab54b65a7b8e09'
'ade86db2b906f3468e014b28ebdd36d6'
- '7ffbac5dffd3ffcf04ffba3c0c1f5bd2'
- '9ee9b4ddbac31567f63520beb4d5628f')
+ '30e9d9e679a8b22d9c5efbf64c14743c'
+ 'e051e06111c73777914dffee61b43afc')
pkgver() {
cd "$srcdir/${pkgname%-git}"
diff --git a/sheepit-client.conf b/sheepit-client.conf
index 67738d9cd30a..eb76d1d4098c 100644
--- a/sheepit-client.conf
+++ b/sheepit-client.conf
@@ -1,8 +1,20 @@
+# Configuration for the sheepit client
+
+# You can either change the following
+# values or run sheepit-client and
+# paste the content of ~/.sheepit.conf
+# here.
+# It is however recommended to
+# set cache-dir to the directory suggested
+# here since the default uses /tmp
+# and it might fill up quickly.
+# The ui setting is overriden by the
+# service so there is no need to change it.
+
# Cache/Working directory. Caution,
# everything in it not related to the
# render-farm will be removed
-cache-dir=
-# cache-dir=/var/lib/sheepit-client/
+cache-dir=/var/cache/sheepit-client/
# CPU: only use cpu, GPU: only use gpu,
# CPU_GPU: can use cpu and gpu (not at
@@ -12,6 +24,8 @@ compute-method=CPU
# CUDA name of the GPU used for the
# render, for example CUDA_0
+# Use sheepit-client --show-gpu
+# to print available CUDA devices
#compute-gpu=CUDA_0
# Number of cores/threads to use for
@@ -26,10 +40,20 @@ password=
# URL of the proxy
proxy=
-# proxy=http://login:password@host:port
+#proxy=http://login:password@host:port
+
+# Set render process priorit (19
+# lowest to -19 highest)
+prority=19
+
+# Maximum time allow for each frame (in
+# minute)
+#rendertime=20
+
+# Maximum memory allow to be used by
+# renderer (in KB)
+#ram=2097152
-# Specify the user interface to use,
-# default 'swing', available 'oneLine',
-# 'text', 'swing' (graphical)
-ui=text
+# Tile size
+#tile-size=128
diff --git a/sheepit-client.install b/sheepit-client.install
index ef6ab2c0657d..b611d967794b 100644
--- a/sheepit-client.install
+++ b/sheepit-client.install
@@ -1,4 +1,8 @@
post_install() {
systemd-sysusers sheepit-client.conf
- [[ -d /var/lib/sheepit-client ]] || install -dm 700 -o sheepit-client -g sheepit-client /var/lib/sheepit-client
+}
+
+post_upgrade() {
+ [[ -d /var/lib/sheepit-client ]] && echo "sheepit-client now uses /var/cache/sheepit-client as a default cache directory. You may want to remove /var/lib/sheepit-client."
+ [[ -d /var/cache/sheepit-client ]] || install -dm 755 -o sheepit-client -g sheepit-client /var/cache/sheepit-client
}
diff --git a/sheepit-client.service b/sheepit-client.service
index cec02bd1348e..b9ddb7e11778 100644
--- a/sheepit-client.service
+++ b/sheepit-client.service
@@ -5,8 +5,8 @@ After=network.target
[Service]
User=sheepit-client
-ExecStart=/usr/bin/sheepit-client -config /etc/conf.d/sheepit-client
-RestartSec=10
+ExecStart=/usr/bin/sheepit-client -config /etc/conf.d/sheepit-client -ui text
+RestartSec=60
Restart=on-failure
[Install]