summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
-rw-r--r--sheepit-client.conf60
-rw-r--r--sheepit-client.service5
-rw-r--r--sheepit-client.sh2
-rw-r--r--sheepit-client.tmpfiles1
6 files changed, 54 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c0ed96870d9..12be2c2e7382 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sheepit-client-git
pkgdesc = Client for the free and distributed render farm
pkgver = 6.2020.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.sheepit-renderfarm.com/
arch = i686
arch = x86_64
@@ -21,15 +21,17 @@ pkgbase = sheepit-client-git
conflicts = sheepit-client
backup = etc/conf.d/sheepit-client
source = git://github.com/laurent-clouet/sheepit-client.git#branch=master
- source = sheepit-client.sh
- source = sheepit-client.sysusers
source = sheepit-client.conf
source = sheepit-client.service
+ source = sheepit-client.sh
+ source = sheepit-client.sysusers
+ source = sheepit-client.tmpfiles
sha256sums = SKIP
- sha256sums = 7e6b48f67f35556aaef7823d5e84b6841c46003b65b9a8c373d1cd14343068a4
+ sha256sums = 69220c93518e1bbd034feded5c5deb4e29e21340151d51096adf269d9ec641af
+ sha256sums = 4181b60d36dda17a6d93698166e46e54049d14490993912eb4b31fa833711ee2
+ sha256sums = 18c3c158263861bca6f61204741f7c7c9ea8201b99ec711bc60d096598f4e8ed
sha256sums = 2ec4f41f996f149102403a0376da75bf6545a80883c595232aa27eedc2eb9803
- sha256sums = 19924349046bc2801ed8532f37d388d6e0317cb5e46b7c13acb5c3069193177d
- sha256sums = 22c9a9461a56e37971a8662308448188164f70caac7e328fc4c7c78a91772af4
+ sha256sums = ba7e49757345d04ae42a8a86fcee3ff53eb9fc86ef8a5b3db8895b5e4b42440a
pkgname = sheepit-client-git
diff --git a/PKGBUILD b/PKGBUILD
index 88c309fe5603..bba74c663e97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sheepit-client-git
pkgver=6.2020.0
-pkgrel=2
+pkgrel=3
pkgdesc="Client for the free and distributed render farm"
arch=('i686' 'x86_64')
url="https://www.sheepit-renderfarm.com/"
@@ -15,32 +15,35 @@ provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=('etc/conf.d/sheepit-client')
source=('git://github.com/laurent-clouet/sheepit-client.git#branch=master'
- 'sheepit-client.sh'
- 'sheepit-client.sysusers'
- 'sheepit-client.conf'
- 'sheepit-client.service')
+ "${pkgname%-git}.conf"
+ "${pkgname%-git}.service"
+ "${pkgname%-git}.sh"
+ "${pkgname%-git}.sysusers"
+ "${pkgname%-git}.tmpfiles")
sha256sums=('SKIP'
- '7e6b48f67f35556aaef7823d5e84b6841c46003b65b9a8c373d1cd14343068a4'
+ '69220c93518e1bbd034feded5c5deb4e29e21340151d51096adf269d9ec641af'
+ '4181b60d36dda17a6d93698166e46e54049d14490993912eb4b31fa833711ee2'
+ '18c3c158263861bca6f61204741f7c7c9ea8201b99ec711bc60d096598f4e8ed'
'2ec4f41f996f149102403a0376da75bf6545a80883c595232aa27eedc2eb9803'
- '19924349046bc2801ed8532f37d388d6e0317cb5e46b7c13acb5c3069193177d'
- '22c9a9461a56e37971a8662308448188164f70caac7e328fc4c7c78a91772af4')
+ 'ba7e49757345d04ae42a8a86fcee3ff53eb9fc86ef8a5b3db8895b5e4b42440a')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${srcdir}/${pkgname%-git}"
printf "%sr%s.%s" "$(git describe --tags --abbrev=0)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/sheepit-client"
+ cd "${srcdir}/${pkgname%-git}"
gradle shadowJar
}
package() {
- install -Dm644 "${srcdir}/sheepit-client/build/libs/sheepit-client.jar" "${pkgdir}/usr/share/java/sheepit-client/sheepit-client.jar"
- install -Dm755 "${srcdir}/sheepit-client.sh" "${pkgdir}/usr/bin/sheepit-client"
- install -Dm644 "${srcdir}/sheepit-client.sysusers" "${pkgdir}/usr/lib/sysusers.d/sheepit-client.conf"
- install -Dm644 "${srcdir}/sheepit-client.conf" "${pkgdir}/etc/conf.d/sheepit-client"
- install -Dm644 "${srcdir}/sheepit-client.service" "${pkgdir}/usr/lib/systemd/system/sheepit-client.service"
+ cd "$srcdir"
+ install -Dm644 "${pkgname%-git}/build/libs/${pkgname%-git}.jar" "${pkgdir}/usr/share/java/${pkgname%-git}/${pkgname%-git}.jar"
+ install -Dm755 "${pkgname%-git}.sh" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 "${pkgname%-git}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname%-git}.conf"
+ install -Dm644 "${pkgname%-git}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname%-git}.conf"
+ install -Dm644 "${pkgname%-git}.conf" "${pkgdir}/etc/conf.d/${pkgname%-git}"
+ install -Dm644 "${pkgname%-git}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname%-git}.service"
}
-
diff --git a/sheepit-client.conf b/sheepit-client.conf
index bcc3ee8ff985..115b1ec6c8df 100644
--- a/sheepit-client.conf
+++ b/sheepit-client.conf
@@ -1,55 +1,37 @@
-# Configuration for the sheepit client
+#Configuration for the sheepit client
-# You can either change the following
-# values or run sheepit-client and
-# paste the content of ~/.sheepit.conf
-# here.
+#User's login
+login=
+
+#User's password or public key
+password=
-# This option must not
-# be changed.
+#This must be set to text for the systemd service to function properly
+#If running the client standalone you can use set it to 'swing' for a graphical interface
ui=text
-# Cache/Working directory. Caution,
-# everything in it not related to the
-# render-farm will be removed.
-# Changing the cache directory
-# requires editing the service
+#This must not be changed if using the systemd service or if running the client as the sheepit-client user
+#You can set it to anywhere you have access to if running the program under your normal user session
+#Caution, everything in it not related to the render-farm will be removed
cache-dir=/var/cache/sheepit-client/
-# CPU: only use cpu, GPU: only use gpu,
-# CPU_GPU: can use cpu and gpu (not at
-# the same time) if gpu is not use it
-# will not use the gpu
-compute-method=CPU
+#CPU: only use cpu, GPU: only use gpu, CPU_GPU: can use cpu and gpu (not at the same time) if gpu is not used it will not use the gpu
+#compute-method=CPU
-# CUDA name of the GPU used for the
-# render, for example CUDA_0
-# Use sheepit-client --show-gpu
-# to print available CUDA devices
-#compute-gpu=CUDA_0
-
-# Number of cores/threads to use for
-# the render
+#Number of cores/threads to use for the render
#cpu-cores=4
-# User's login
-login=
+#Maximum memory allow to be used by renderer (in MB)
+#ram=2000M
-# User's password or public key
-password=
+#CUDA name of the GPU used for the render, for example CUDA_0. Use sheepit-client --show-gpu to print available CUDA devices
+#compute-gpu=CUDA_0
-# URL of the proxy
-proxy=
+#URL of the proxy
#proxy=http://login:password@host:port
-# Set render process priorit (19
-# lowest to -19 highest)
+#Set render process priorit (19 lowest to -19 highest)
#prority=19
-# Maximum time allow for each frame (in
-# minute)
+#Maximum time allow for each frame (in minutes)
#rendertime=20
-
-# Maximum memory allow to be used by
-# renderer (in MB).
-#ram=2000M
diff --git a/sheepit-client.service b/sheepit-client.service
index c1a0730f7459..8a090216e404 100644
--- a/sheepit-client.service
+++ b/sheepit-client.service
@@ -9,9 +9,12 @@ NoNewPrivileges=true
ProtectSystem=strict
ProtectHome=true
PrivateDevices=true
+ProtectKernelTunables=true
+ProtectControlGroups=true
RestrictNamespaces=true
CacheDirectory=sheepit-client/
-ExecStart=/usr/bin/sheepit-client
+CacheDirectoryMode=700
+ExecStart=/usr/bin/sheepit-client -config /etc/conf.d/sheepit-client
RestartSec=60
Restart=on-failure
diff --git a/sheepit-client.sh b/sheepit-client.sh
index 59c85519980a..f40bc241ca77 100644
--- a/sheepit-client.sh
+++ b/sheepit-client.sh
@@ -1,2 +1,2 @@
#!/bin/bash
-exec /bin/java -jar /usr/share/java/sheepit-client/sheepit-client.jar -config /etc/conf.d/sheepit-client
+exec /bin/java -jar /usr/share/java/sheepit-client/sheepit-client.jar "$@"
diff --git a/sheepit-client.tmpfiles b/sheepit-client.tmpfiles
new file mode 100644
index 000000000000..ef0055cdbdc8
--- /dev/null
+++ b/sheepit-client.tmpfiles
@@ -0,0 +1 @@
+d /var/cache/sheepit-client 0700 sheepit-client sheepit-client