summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96dd12740e25..a44f5ccc1e04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sheldon
pkgdesc = A fast and configurable shell plugin manager
pkgver = 0.6.6
- pkgrel = 1
+ pkgrel = 2
url = https://sheldon.cli.rs
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 7e68ec28fef1..2af5eb3dc5e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=sheldon
pkgver=0.6.6
-pkgrel=1
+pkgrel=2
pkgdesc="A fast and configurable shell plugin manager"
arch=('x86_64')
url="https://sheldon.cli.rs"
@@ -16,11 +16,17 @@ b2sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --tags | sed 's/^[vV]//;s/-/+/g'
+
+ git describe --tags | sed 's/^v//'
}
prepare() {
cd "$pkgname"
+
+ # backport fix for tests
+ git cherry-pick --no-commit 9aa06fdd5cb284daae8c48648d614e3823f3f9f3
+
+ # download dependencies
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
@@ -36,6 +42,7 @@ build() {
check() {
cd "$pkgname"
+
cargo test --frozen --all-features
}