summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.INSTALL14
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
3 files changed, 55 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..61876aba19d3
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,14 @@
+post_install() {
+ echo ". /usr/share/shell-mommy/shell-mommy.sh" >> "$(getent passwd $SUDO_USER | cut -d: -f6)/.bashrc"
+ printf "Installed -- Don't forget to restart your shell!\n"
+}
+
+post_upgrade() {
+ echo ". /usr/share/shell-mommy/shell-mommy.sh" >> "$(getent passwd $SUDO_USER | cut -d: -f6)/.bashrc"
+ printf "Installed -- Don't forget to restart your shell!\n"
+}
+
+post_remove() {
+ sed -i "/. \/usr\/share\/shell-mommy\/shell-mommy.sh/d" "$(getent passwd $SUDO_USER | cut -d: -f6)/.bashrc"
+ printf "Removed -- Don't forget to restart your shell!\n"
+} \ No newline at end of file
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90bb772cc401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = shell-mommy-git
+ pkgdesc = Mommy is here for you on the command line ~ <3
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/sudofox/shell-mommy
+ install = .INSTALL
+ arch = any
+ license = unknown
+ makedepends = git
+ source = shell-mommy-git::git+https://github.com/sudofox/shell-mommy.git
+ source = .INSTALL
+ sha256sums = SKIP
+ sha256sums = 205d7dce822e5e725aa919b54ffad53ae93466133b5b10aad5ba0ab88ee698eb
+ b2sums = SKIP
+ b2sums = 052fc2752e7e9507a8e861624f8fc487b51f4ec88327b2ca3b1daf451b0915b9278ad8079b2acc092a7798b47be8f770064fcc158eaf5fce9607ec5862567571
+
+pkgname = shell-mommy-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a76908907e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: J0w03L <j0w03l at email dot com>
+pkgname=shell-mommy-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Mommy is here for you on the command line ~ <3"
+arch=("any")
+url="https://github.com/sudofox/shell-mommy"
+license=("unknown")
+makedepends=("git")
+install=.INSTALL
+source=("$pkgname::git+https://github.com/sudofox/shell-mommy.git"
+ .INSTALL)
+sha256sums=("SKIP"
+ "205d7dce822e5e725aa919b54ffad53ae93466133b5b10aad5ba0ab88ee698eb")
+b2sums=("SKIP"
+ "052fc2752e7e9507a8e861624f8fc487b51f4ec88327b2ca3b1daf451b0915b9278ad8079b2acc092a7798b47be8f770064fcc158eaf5fce9607ec5862567571")
+prepare() {
+ cp "$HOME/.bashrc" "$HOME/.bashrc.bak"
+}
+package() {
+ cd "$pkgname"
+ sudo mkdir -p "/usr/share/shell-mommy"
+ sudo cp "shell-mommy.sh" "/usr/share/shell-mommy/shell-mommy.sh"
+}