summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
-rw-r--r--shellinabox@.service2
3 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be408de39afa..628e3169d5da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,5 @@
pkgbase = shellinabox-git
+ pkgdesc = Implementation of a web server that can export arbitrary command line tools to a web based terminal emulator
pkgver = 2.14
pkgrel = 1
url = https://code.google.com/p/shellinabox/
@@ -6,6 +7,8 @@ pkgbase = shellinabox-git
license = GPL2
makedepends = git
makedepends = gcc
+ source = shellinabox@.service
+ md5sums = 21e4bf31bdf577e858580b75b2171e1d
pkgname = shellinabox-git
diff --git a/PKGBUILD b/PKGBUILD
index 4613db8faad4..acca723cecaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,9 @@ replaces=()
backup=()
options=()
install=
-source=()
+source=('shellinabox@.service')
noextract=()
-md5sums=() #generate with 'makepkg -g'
+md5sums=('f67bac96ac703c7e45881d38df21dd27') #generate with 'makepkg -g'
_gitroot=$url
_gitname=shellinabox
@@ -56,6 +56,7 @@ build() {
package() {
cd "$srcdir/$_gitname-build"
make DESTDIR="$pkgdir/" install
+ install -Dm655 "$srcdir/shellinabox@.service" "$pkgdir/usr/lib/systemd/system/shellinabox@.service"
}
# vim:set ts=2 sw=2 et:
diff --git a/shellinabox@.service b/shellinabox@.service
index f4e94447d25f..c1b23356e5c4 100644
--- a/shellinabox@.service
+++ b/shellinabox@.service
@@ -5,7 +5,7 @@ Description=Shell In a Box service
Type=oneshot
RemainAfterExit=yes
User=%i
-ExecStart=shellinaboxd -b -s '/:SSH:localhost' --localhost-only -c ~/.config
+ExecStart=shellinaboxd -b -s '/:SSH:localhost' --localhost-only -c /tmp
[Install]
WantedBy=multi-user.target