summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..870ac4b9e23b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = shfmt-bin
+ pkgdesc = Format shell programs (pre-compiled static binary)
+ pkgver = 2.5.0
+ pkgrel = 1
+ url = https://github.com/mvdan/sh
+ arch = x86_64
+ license = BSD
+ provides = shfmt
+ conflicts = shfmt
+ source_x86_64 = https://github.com/mvdan/sh/releases/download/v2.5.0/shfmt_v2.5.0_linux_amd64
+ source_x86_64 = https://raw.githubusercontent.com/mvdan/sh/v2.5.0/LICENSE
+ sha256sums_x86_64 = fce24cfa408362e6802f1cec9b2b9f92fb865eb8ae1233ee2874b5d0c66b2f91
+ sha256sums_x86_64 = SKIP
+
+pkgname = shfmt-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7358f49e518
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Daniel Martí <mvdan@mvdan.cc>
+
+pkgname=shfmt-bin
+_pkg=sh
+_name=shfmt
+pkgver=2.5.0
+pkgrel=1
+pkgdesc="Format shell programs (pre-compiled static binary)"
+url="https://github.com/mvdan/${_pkg}"
+license=('BSD')
+provides=('shfmt')
+conflicts=('shfmt')
+
+arch=('x86_64')
+source_x86_64=(
+ "https://github.com/mvdan/sh/releases/download/v${pkgver}/shfmt_v${pkgver}_linux_amd64"
+ "https://raw.githubusercontent.com/mvdan/sh/v${pkgver}/LICENSE"
+)
+sha256sums_x86_64=(
+ 'fce24cfa408362e6802f1cec9b2b9f92fb865eb8ae1233ee2874b5d0c66b2f91'
+ 'SKIP'
+)
+
+package() {
+ install -Dm755 shfmt_v${pkgver}_linux_amd64 "${pkgdir}/usr/bin/${_name}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}