summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
-rw-r--r--support-new-python.diff14
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1af0bfbc042..4ce1f6919f0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = shiboken
source = shiboken-1.2.4.tar.gz::https://github.com/PySide/Shiboken/archive/1.2.4.tar.gz
source = support-new-python.diff
md5sums = c284197d06ad25d78009ff55f18dd512
- md5sums = 84844a6459a5fccb3ec2d6418a1af3fd
+ md5sums = c7d70851fa057dc843aca978b2b52a4b
pkgname = python2-shiboken
pkgdesc = Support library for Python2 bindings
@@ -35,4 +35,3 @@ pkgname = shiboken
depends = libxslt
optdepends = python2-shiboken: for compilation against python2
optdepends = python-shiboken: for compilation against python
-
diff --git a/PKGBUILD b/PKGBUILD
index 7b0ff954fef0..13e3818a61b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Andrew Sun <adsun701 at gmail dot com>
# Contributor: Florian Pritz <bluewind at xinu dot at>
# Contributor: Jelle van der Waa <jelle@ at vdwaa dot nl>
# Contributor: Hugo Osvaldo Barrera <hugo at barrera dot io>
@@ -15,7 +15,7 @@ makedepends=('cmake' 'python2' 'python' 'qt4' 'libxslt')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/PySide/Shiboken/archive/$pkgver.tar.gz"
support-new-python.diff)
md5sums=('c284197d06ad25d78009ff55f18dd512'
- '84844a6459a5fccb3ec2d6418a1af3fd')
+ 'c7d70851fa057dc843aca978b2b52a4b')
prepare(){
cd "$srcdir/Shiboken-$pkgver"
diff --git a/support-new-python.diff b/support-new-python.diff
index 9180d02d524c..3a008396691f 100644
--- a/support-new-python.diff
+++ b/support-new-python.diff
@@ -10,14 +10,20 @@
SET(_32FLAGS "m" "u" "mu" "dm" "du" "dmu" "")
ELSE()
--- a/libshiboken/sbkenum.cpp 2021-02-09 14:52:17.062065563 ->
-+++ b/libshiboken/sbkenum.cpp 2021-02-09 14:52:59.965800766 ->
-@@ -529,7 +529,9 @@
++++ b/libshiboken/sbkenum.cpp 2021-02-09 14:52:59.965800766 ->
+@@ -527,9 +527,15 @@
+ {
+ PyTypeObject* type = reinterpret_cast<PyTypeObject*>(new SbkEnumType);
::memset(type, 0, sizeof(SbkEnumType));
++ #ifdef IS_PY3K
++ Py_SET_TYPE(type, &SbkEnumType_Type);
++ #else
Py_TYPE(type) = &SbkEnumType_Type;
++ #endif
type->tp_basicsize = sizeof(SbkEnumObject);
-+#ifndef IS_PY3K
++ #ifndef IS_PY3K
type->tp_print = &SbkEnumObject_print;
-+#endif
++ #endif
type->tp_repr = &SbkEnumObject_repr;
type->tp_str = &SbkEnumObject_repr;
type->tp_flags = Py_TPFLAGS_DEFAULT|Py_TPFLAGS_CHECKTYPES;