summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD123
3 files changed, 64 insertions, 109 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d97a108b90c..0adccaace9b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,42 +1,30 @@
pkgbase = shiboken2-git
- pkgver = 5.12.2.r6266.54f48761
+ pkgver = 5.15.3
pkgrel = 1
- url = http://www.pyside.org
- arch = i686
+ url = https://www.qt.io
arch = x86_64
license = LGPL
- makedepends = git
+ makedepends = clang=15.0.7
makedepends = llvm
- makedepends = clang
makedepends = cmake
- makedepends = python2
- makedepends = python
+ makedepends = git
makedepends = libxslt
makedepends = qt5-xmlpatterns
- source = shiboken2-git::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.12
+ makedepends = python39
+ source = shiboken2::git+https://code.qt.io/pyside/pyside-setup.git#commit=72d32f66685fbb7fefc41eee629e63f4824cb10b
sha256sums = SKIP
-pkgname = python2-shiboken2-git
- pkgdesc = Support library for Python2 bindings
- depends = python2
- depends = shiboken2-git
- provides = python2-shiboken2=5.12.2
- conflicts = python2-shiboken2
-
-pkgname = python-shiboken2-git
- pkgdesc = Support library for Python bindings
- depends = python
- depends = shiboken2-git
- provides = python-shiboken2=5.12.2
- conflicts = python-shiboken2
-
pkgname = shiboken2-git
- pkgdesc = CPython bindings generator for C++ libraries
+ pkgdesc = Generates bindings for C++ libraries using CPython source code (git version)
+ depends = clang=15.0.7
+ depends = llvm
depends = libxslt
- depends = clang
depends = qt5-xmlpatterns
- optdepends = python2-shiboken2-git: for compilation against python2
- optdepends = python-shiboken2-git: for compilation against python
- provides = shiboken2=5.12.2
+ provides = shiboken2=5.15.3
conflicts = shiboken2
+pkgname = python-shiboken2-git
+ pkgdesc = Python bindings for shiboken2 (git version)
+ depends = python39
+ provides = python-shiboken2=5.15.3
+ conflicts = python-shiboken2
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index eeaf99a61cea..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,8 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!.SRCINFO
-!*.install
-!ChangeLog
-!*.diff
-!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index af3488f38f62..9a0c742d38e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,98 +1,73 @@
-# Maintainer: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Cebtenzzre <cebtenzzre (at) gmail (dot) com>
# Contributor: Markus Hovorka <m.hovorka@live.de>
# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
# Contributor: Matthias Maennich <arch@maennich.net>
+_pkgbase=shiboken2
pkgbase=shiboken2-git
-pkgname=(python{2,}-shiboken2-git shiboken2-git)
-pkgver=5.12.2.r6266.54f48761
+pkgname=(shiboken2-git python-shiboken2-git)
+_clangver=15.0.7
+pkgver=5.15.3
pkgrel=1
-arch=('i686' 'x86_64')
-license=('LGPL')
-url="http://www.pyside.org"
-makedepends=('git' 'llvm' 'clang' 'cmake' 'python2' 'python' 'libxslt'
- 'qt5-xmlpatterns')
-source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.12")
+arch=(x86_64)
+url='https://www.qt.io'
+license=(LGPL)
+makedepends=(clang=$_clangver llvm cmake git libxslt qt5-xmlpatterns python39)
+_commit=72d32f66685fbb7fefc41eee629e63f4824cb10b # tags/v5.15.3-lts-lgpl^0
+source=("$_pkgbase::git+https://code.qt.io/pyside/pyside-setup.git#commit=$_commit")
sha256sums=('SKIP')
-pkgver() {
- cd "$srcdir/$pkgbase"
- _upver="$(python sources/shiboken2/shiboken_version.py | cut -d';' -f-3 | tr ';' '.')"
- printf "%s.r%s.%s" "$_upver" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
-build() {
- # Build for python2.
- cd "$srcdir"/$pkgbase/sources/shiboken2
- cmake_args="-DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTS=OFF -DCMAKE_CXX_COMPILER=/usr/bin/clang++"
- mkdir -p build-py2 && cd build-py2
- cmake \
- -DUSE_PYTHON_VERSION=2 \
- ${cmake_args} ..
- make
+prepare() {
+ cd "$_pkgbase"
- # Build for python3.
- cd "$srcdir"/$pkgbase/sources/shiboken2
- mkdir -p build-py3 && cd build-py3
- cmake \
- -DUSE_PYTHON_VERSION=3 \
- ${cmake_args} ..
- make
+ mkdir -p build
}
-package_shiboken2-git() {
- pkgdesc="CPython bindings generator for C++ libraries"
- depends=('libxslt' 'clang' 'qt5-xmlpatterns')
- optdepends=("python2-shiboken2-git: for compilation against python2"
- "python-shiboken2-git: for compilation against python")
- provides=("shiboken2=${pkgver%%.r*}")
- conflicts=("shiboken2")
+_python=/usr/bin/python3.9
- cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
- make DESTDIR="$pkgdir" install
+build() {
+ # make a venv which has setuptools available
+ "$_python" -m venv --system-site-packages pkg-venv
- _upver=${pkgver%%.r*}
- rm -rf "$pkgdir/usr/lib/python"*
- rm -rf "$pkgdir/usr/lib/libshiboken2"*
- rm -rf "$pkgdir/usr/lib/pkgconfig/"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Config*python*.cmake
+ cmake -B build -S "$_pkgbase/sources/shiboken2" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DBUILD_TESTS=OFF \
+ -DPYTHON_EXECUTABLE=$_python
+ cmake --build build
}
-package_python2-shiboken2-git() {
- pkgdesc="Support library for Python2 bindings"
- depends=("python2" "shiboken2-git")
- provides=("python2-shiboken2=${pkgver%%.r*}")
- conflicts=("python2-shiboken2")
-
- cd "$srcdir"/$pkgbase/sources/shiboken2/build-py2
- make DESTDIR="$pkgdir" install
-
- mv "$pkgdir"/usr/lib/pkgconfig/shiboken2{,-py2}.pc
+package_shiboken2-git() {
+ pkgdesc='Generates bindings for C++ libraries using CPython source code (git version)'
+ depends=(clang=$_clangver llvm libxslt qt5-xmlpatterns)
+ conflicts=(shiboken2)
+ provides=(shiboken2=$pkgver)
- _upver="${pkgver%%.r*}"
- rm -rf "$pkgdir"/usr/{include,bin,share}
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2ConfigVersion.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2Config.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Targets{,-release}.cmake
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/shiboken_helpers.cmake"
+ DESTDIR="$pkgdir" cmake --install build
+# Provided in python-shiboken2
+ rm -r "$pkgdir"/usr/lib/{python*,libshiboken*}
+# Conflicts with shiboken6 and doesn't work anyway
+ rm "$pkgdir"/usr/bin/shiboken_tool.py
}
package_python-shiboken2-git() {
- pkgdesc="Support library for Python bindings"
- depends=("python" "shiboken2-git")
- _upver="${pkgver%%.r*}"
- provides=("python-shiboken2=${pkgver%%.r*}")
- conflicts=("python-shiboken2")
+ pkgdesc='Python bindings for shiboken2 (git version)'
+ depends=(python39)
+ conflicts=(python-shiboken2)
+ provides=(python-shiboken2=$pkgver)
- cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
+# Provided in shiboken2
+ rm -r "$pkgdir"/usr/{bin,include,lib/{cmake,pkgconfig}}
- _upver="${pkgver%%.r*}"
- rm -rf "$pkgdir"/usr/{include,bin,share}
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2ConfigVersion.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/Shiboken2Config.cmake"
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Targets{,-release}.cmake
- rm "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}/shiboken_helpers.cmake"
+# Install egg-info
+ source pkg-venv/bin/activate
+ cd "$_pkgbase"
+ python setup.py egg_info --build-type=shiboken2
+ _pythonpath=$("$_python" -c "from sysconfig import get_path; print(get_path('platlib'))")
+ cp -r shiboken2.egg-info "$pkgdir"/$_pythonpath
+ deactivate
}