summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD48
-rw-r--r--sphinx-build2.patch18
3 files changed, 31 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e59d8901d591..b852fe929254 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,7 @@
+# Generated by mksrcinfo v8
+# Thu Nov 16 22:24:26 UTC 2017
pkgbase = shiboken2-git
- pkgver = 2.0.0.r2539.8f3761d
+ pkgver = 2.0.0.r5325.ad14f649
pkgrel = 1
url = http://www.pyside.org
arch = i686
@@ -7,16 +9,13 @@ pkgbase = shiboken2-git
license = LGPL
makedepends = git
makedepends = clang
- makedepends = llvm
makedepends = cmake
makedepends = python2
makedepends = python
makedepends = libxslt
makedepends = qt5-xmlpatterns
- source = shiboken2-git::git+https://code.qt.io/pyside/shiboken.git#branch=5.9
- source = sphinx-build2.patch
- md5sums = SKIP
- md5sums = 915d0fc351ff2e7c5deaa1066aeeae67
+ source = shiboken2-git::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.9
+ sha256sums = SKIP
pkgname = python2-shiboken2-git
pkgdesc = Support library for Python2 bindings
diff --git a/PKGBUILD b/PKGBUILD
index d6fa38724507..994f097ab9d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Markus Hovorka <m.hovorka@live.de>
+# Contributor: Markus Hovorka <m.hovorka@live.de>
# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
# Contributor: Hugo Osvaldo Barrera <hugo@barrera.io>
@@ -6,18 +6,16 @@
pkgbase=shiboken2-git
pkgname=(python{2,}-shiboken2-git shiboken2-git)
-pkgver=2.0.0.r2539.8f3761d
+pkgver=2.0.0.r5325.ad14f649
_upver=2.0.0
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
url="http://www.pyside.org"
-makedepends=('git' 'clang' 'llvm' 'cmake' 'python2' 'python' 'libxslt'
+makedepends=('git' 'clang' 'cmake' 'python2' 'python' 'libxslt'
'qt5-xmlpatterns')
-source=("$pkgbase::git+https://code.qt.io/pyside/shiboken.git#branch=5.9"
- "sphinx-build2.patch")
-md5sums=('SKIP'
- '915d0fc351ff2e7c5deaa1066aeeae67')
+source=("$pkgbase::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.9")
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgbase"
@@ -26,27 +24,33 @@ pkgver() {
prepare() {
cd "$srcdir/$pkgbase"
- patch -Np1 -i "$srcdir/sphinx-build2.patch"
}
build(){
# Build for python2.
- cd "$srcdir/$pkgbase"
+ cd "$srcdir"/$pkgbase/sources/shiboken2
mkdir -p build-py2 && cd build-py2
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DPYTHON_EXTENSION_SUFFIX=-python2.7 \
- -DUSE_PYTHON_VERSION=2 \
- -DBUILD_TESTS=OFF
+ cmake \
+ -DCMAKE_C_COMPILER=/usr/bin/clang \
+ -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=2 \
+ -DBUILD_TESTS=OFF ..
make
# Build for python3.
- cd "$srcdir/$pkgbase"
+ cd "$srcdir"/$pkgbase/sources/shiboken2
mkdir -p build-py3 && cd build-py3
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DUSE_PYTHON_VERSION=3 \
- -DBUILD_TESTS=OFF
+ cmake \
+ -DCMAKE_C_COMPILER=/usr/bin/clang \
+ -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTS=OFF \
+ -DUSE_PYTHON_VERSION=3 \
+ -DBUILD_TESTS=OFF ..
make
}
@@ -56,7 +60,7 @@ package_shiboken2-git() {
optdepends=("python2-shiboken2-git: for compilation against python2"
"python-shiboken2-git: for compilation against python")
- cd "$srcdir/$pkgbase/build-py3"
+ cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir/usr/lib/python"*
@@ -69,7 +73,7 @@ package_python2-shiboken2-git() {
pkgdesc="Support library for Python2 bindings"
depends=("python2" "shiboken2-git")
- cd "$srcdir/$pkgbase/build-py2"
+ cd "$srcdir"/$pkgbase/sources/shiboken2/build-py2
make DESTDIR="$pkgdir" install
mv "$pkgdir"/usr/lib/pkgconfig/shiboken2{,-py2}.pc
@@ -83,7 +87,7 @@ package_python-shiboken2-git() {
pkgdesc="Support library for Python bindings"
depends=("python" "shiboken2-git")
- cd "$srcdir/$pkgbase/build-py3"
+ cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/{include,bin,share}
diff --git a/sphinx-build2.patch b/sphinx-build2.patch
deleted file mode 100644
index 7e73a4e0bc12..000000000000
--- a/sphinx-build2.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/ApiExtractor/doc/CMakeLists.txt b/ApiExtractor/doc/CMakeLists.txt
-index d78844d..e9245e1 100644
---- a/ApiExtractor/doc/CMakeLists.txt
-+++ b/ApiExtractor/doc/CMakeLists.txt
-@@ -1,5 +1,5 @@
-
--find_program(SPHINX sphinx-build DOC "Path to sphinx-build binary.")
-+find_program(SPHINX sphinx-build2 DOC "Path to sphinx-build binary.")
-
- if (SPHINX)
- message("-- sphinx-build - found")
-@@ -7,4 +7,4 @@ if (SPHINX)
- add_custom_target(doc ${SPHINX} -b html -c . ${CMAKE_CURRENT_SOURCE_DIR} html )
- else()
- message("-- sphinx-build - not found! doc target disabled")
--endif()
-\ No newline at end of file
-+endif()