summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 20 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca5bd006bcf9..e59d8901d591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,38 @@
pkgbase = shiboken2-git
- pkgver = 2.0.0.r2506.47676b5
+ pkgver = 2.0.0.r2539.8f3761d
pkgrel = 1
url = http://www.pyside.org
arch = i686
arch = x86_64
license = LGPL
makedepends = git
+ makedepends = clang
+ makedepends = llvm
makedepends = cmake
- makedepends = qt5.6
makedepends = python2
makedepends = python
makedepends = libxslt
- source = shiboken2-git::git+https://code.qt.io/pyside/shiboken.git#branch=5.6
+ makedepends = qt5-xmlpatterns
+ source = shiboken2-git::git+https://code.qt.io/pyside/shiboken.git#branch=5.9
source = sphinx-build2.patch
md5sums = SKIP
md5sums = 915d0fc351ff2e7c5deaa1066aeeae67
pkgname = python2-shiboken2-git
pkgdesc = Support library for Python2 bindings
- depends = qt5.6
- depends = libxslt
depends = python2
depends = shiboken2-git
pkgname = python-shiboken2-git
pkgdesc = Support library for Python bindings
- depends = libxslt
depends = python
depends = shiboken2-git
pkgname = shiboken2-git
pkgdesc = CPython bindings generator for C++ libraries
- depends = qt5.6
- depends = python
depends = libxslt
+ depends = clang
+ depends = qt5-xmlpatterns
optdepends = python2-shiboken2-git: for compilation against python2
optdepends = python-shiboken2-git: for compilation against python
diff --git a/PKGBUILD b/PKGBUILD
index 672db7c2e307..d6fa38724507 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,15 @@
pkgbase=shiboken2-git
pkgname=(python{2,}-shiboken2-git shiboken2-git)
-pkgver=2.0.0.r2506.47676b5
+pkgver=2.0.0.r2539.8f3761d
_upver=2.0.0
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
url="http://www.pyside.org"
-makedepends=('git' 'cmake' 'qt5.6' 'python2' 'python' 'libxslt')
-source=("$pkgbase::git+https://code.qt.io/pyside/shiboken.git#branch=5.6"
+makedepends=('git' 'clang' 'llvm' 'cmake' 'python2' 'python' 'libxslt'
+ 'qt5-xmlpatterns')
+source=("$pkgbase::git+https://code.qt.io/pyside/shiboken.git#branch=5.9"
"sphinx-build2.patch")
md5sums=('SKIP'
'915d0fc351ff2e7c5deaa1066aeeae67')
@@ -29,16 +30,13 @@ prepare() {
}
build(){
- local qt5_src="/opt/qt5.6"
- local qt5_rpath="/opt/qt5.6/lib"
-
# Build for python2.
cd "$srcdir/$pkgbase"
mkdir -p build-py2 && cd build-py2
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- "-DCMAKE_PREFIX_PATH=$qt5_src" \
- "-DCMAKE_INSTALL_RPATH=$qt5_rpath" \
+ -DPYTHON_EXTENSION_SUFFIX=-python2.7 \
+ -DUSE_PYTHON_VERSION=2 \
-DBUILD_TESTS=OFF
make
@@ -47,18 +45,16 @@ build(){
mkdir -p build-py3 && cd build-py3
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- "-DCMAKE_PREFIX_PATH=$qt5_src" \
- "-DCMAKE_INSTALL_RPATH=$qt5_rpath" \
- -DBUILD_TESTS=OFF \
- -DUSE_PYTHON_VERSION=3
+ -DUSE_PYTHON_VERSION=3 \
+ -DBUILD_TESTS=OFF
make
}
package_shiboken2-git() {
pkgdesc="CPython bindings generator for C++ libraries"
- depends=('qt5.6' 'python' 'libxslt')
+ depends=('libxslt' 'clang' 'qt5-xmlpatterns')
optdepends=("python2-shiboken2-git: for compilation against python2"
- "python-shiboken2-git: for compilation against python")
+ "python-shiboken2-git: for compilation against python")
cd "$srcdir/$pkgbase/build-py3"
make DESTDIR="$pkgdir" install
@@ -71,23 +67,21 @@ package_shiboken2-git() {
package_python2-shiboken2-git() {
pkgdesc="Support library for Python2 bindings"
- depends=('qt5.6' "libxslt" "python2" "shiboken2-git")
+ depends=("python2" "shiboken2-git")
cd "$srcdir/$pkgbase/build-py2"
make DESTDIR="$pkgdir" install
- install -Dm 644 data/Shiboken2Config.cmake "$pkgdir/usr/lib/cmake/Shiboken2-$_upver/"
-
mv "$pkgdir"/usr/lib/pkgconfig/shiboken2{,-py2}.pc
- mv "$pkgdir/usr/lib/cmake/Shiboken2-${_upver}"/Shiboken2Config{,-python2.7}.cmake
rm -rf "$pkgdir"/usr/{include,bin,share}
rm "$pkgdir/usr/lib/cmake/Shiboken2-$_upver/Shiboken2ConfigVersion.cmake"
+ rm "$pkgdir/usr/lib/cmake/Shiboken2-$_upver/Shiboken2Config.cmake"
}
package_python-shiboken2-git() {
pkgdesc="Support library for Python bindings"
- depends=("libxslt" "python" "shiboken2-git")
+ depends=("python" "shiboken2-git")
cd "$srcdir/$pkgbase/build-py3"
make DESTDIR="$pkgdir" install