summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 15 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 640731ac196d..2c8c446600fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
# Generated by mksrcinfo v8
-# Tue May 29 18:54:05 UTC 2018
+# Wed Jun 13 17:39:20 UTC 2018
pkgbase = shiboken2-git
- pkgver = 5.11.0.r5741.a1a8cf65
+ pkgver = 5.11.0.r5793.bdc29864
pkgrel = 1
url = http://www.pyside.org
arch = i686
@@ -22,11 +22,15 @@ pkgname = python2-shiboken2-git
pkgdesc = Support library for Python2 bindings
depends = python2
depends = shiboken2-git
+ provides = python2-shiboken2
+ conflicts = python2-shiboken2
pkgname = python-shiboken2-git
pkgdesc = Support library for Python bindings
depends = python
depends = shiboken2-git
+ provides = python-shiboken2
+ conflicts = python-shiboken2
pkgname = shiboken2-git
pkgdesc = CPython bindings generator for C++ libraries
@@ -35,4 +39,6 @@ pkgname = shiboken2-git
depends = qt5-xmlpatterns
optdepends = python2-shiboken2-git: for compilation against python2
optdepends = python-shiboken2-git: for compilation against python
+ provides = shiboken2
+ conflicts = shiboken2
diff --git a/PKGBUILD b/PKGBUILD
index c1e4f46e60fa..5b9f226c8b63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=shiboken2-git
pkgname=(python{2,}-shiboken2-git shiboken2-git)
-pkgver=5.11.0.r5741.a1a8cf65
+pkgver=5.11.0.r5793.bdc29864
_upver=5.11.0
pkgrel=1
arch=('i686' 'x86_64')
@@ -50,6 +50,8 @@ package_shiboken2-git() {
depends=('libxslt' 'clang' 'qt5-xmlpatterns')
optdepends=("python2-shiboken2-git: for compilation against python2"
"python-shiboken2-git: for compilation against python")
+ provides=("shiboken2")
+ conflicts=("shiboken2")
cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
make DESTDIR="$pkgdir" install
@@ -63,6 +65,8 @@ package_shiboken2-git() {
package_python2-shiboken2-git() {
pkgdesc="Support library for Python2 bindings"
depends=("python2" "shiboken2-git")
+ provides=("python2-shiboken2")
+ conflicts=("python2-shiboken2")
cd "$srcdir"/$pkgbase/sources/shiboken2/build-py2
make DESTDIR="$pkgdir" install
@@ -77,6 +81,8 @@ package_python2-shiboken2-git() {
package_python-shiboken2-git() {
pkgdesc="Support library for Python bindings"
depends=("python" "shiboken2-git")
+ provides=("python-shiboken2")
+ conflicts=("python-shiboken2")
cd "$srcdir"/$pkgbase/sources/shiboken2/build-py3
make DESTDIR="$pkgdir" install