summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..642e9e70a0c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = shine
+ pkgdesc = Super fast fixed-point MP3 encoder
+ pkgver = 3.1.0
+ pkgrel = 1
+ url = https://github.com/savonet/shine
+ arch = arm
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = make
+ makedepends = libtool
+ depends = glibc
+ options = !libtool
+ options = !strip
+ source = https://github.com/savonet/shine/archive/3.1.0.tar.gz
+ sha256sums = d2b6d09d670a1585d103ed26ea754be76dd3a07033da0a118e8f586ee2ada5e3
+
+pkgname = shine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4be4c372eda6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Dmitry Kharitonov <darksab0r at gmail com>
+# Contributor: Matthias Grosser <mtgrosser at gmx dot net>
+# Contributor: Leonard de Ruijter <leonard@aur.archlinux.org>
+
+pkgname=shine
+pkgver=3.1.0
+pkgrel=1
+pkgdesc='Super fast fixed-point MP3 encoder'
+arch=('arm' 'i686' 'x86_64')
+url='https://github.com/savonet/shine'
+source="https://github.com/savonet/$pkgname/archive/$pkgver.tar.gz"
+license=(GPL2)
+depends=('glibc')
+makedepends=('automake' 'autoconf' 'make' 'libtool')
+options=('!libtool' '!strip')
+sha256sums=('d2b6d09d670a1585d103ed26ea754be76dd3a07033da0a118e8f586ee2ada5e3')
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+