summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 6 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 115481a9b378..27170b9a7a04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = shortcut-git
pkgdesc = A commandline client to list shortcuts
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mt-empty/shortcut-c-client
arch = x86_64
license = unknown
makedepends = git
source = shortcut-pages::git+https://github.com/mt-empty/shortcut-pages.git
source = shortcut-c-client::git+https://github.com/mt-empty/shortcut-c-client.git
- source = shortcut-c-client.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = f9b9c032afda9f3312bc4cc3edd6890bc7ad0d76174aaaeac1af03a0f134bfc2
pkgname = shortcut-pages-git
pkgdesc = A collections of keyboard shortcuts for Desktop application and websites
diff --git a/PKGBUILD b/PKGBUILD
index e39d135a5bd1..d5282c253629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,25 @@
pkgbase=shortcut-git
pkgname=('shortcut-pages-git' 'shortcut-pages-extra-git' 'shortcut-c-client-git')
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="A commandline client to list shortcuts"
url="https://github.com/mt-empty/shortcut-c-client"
arch=('x86_64')
license=('unknown')
makedepends=('git')
source=("shortcut-pages::git+https://github.com/mt-empty/shortcut-pages.git"
- "shortcut-c-client::git+https://github.com/mt-empty/shortcut-c-client.git"
- "shortcut-c-client.patch")
+ "shortcut-c-client::git+https://github.com/mt-empty/shortcut-c-client.git")
sha256sums=('SKIP'
- 'SKIP'
- 'f9b9c032afda9f3312bc4cc3edd6890bc7ad0d76174aaaeac1af03a0f134bfc2')
+ 'SKIP')
pkgver() {
cd "${srcdir}/shortcut-pages"
printf "0.2.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/shortcut-c-client"
- # patch -Np1 --input "${srcdir}/shortcut-c-client.patch"
-
-}
-
build() {
cd "${srcdir}/shortcut-c-client"
- make shortcut
+ make DEST_DIR="/usr/share" shortcut
}
@@ -55,7 +47,7 @@ package_shortcut-pages-extra-git() {
license=('unknown')
provides=('shortcut-pages-extra' 'shortcut-pages')
- cd "$srcdir/shortcut-pages/nonGUI"
+ cd "$srcdir/shortcut-pages/misc/nonGUI"
install -dvm755 "${pkgdir}/usr/share/shortcut/pages"
find . -type f -iname "*.md" -not -regex "\.\/\(c\|git\|r\|unity\|\)\.md$" -exec \