summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
-rw-r--r--cmake-threadlib.patch28
3 files changed, 41 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17ff3a02cca2..17f9914b6e65 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = shrew-vpn-client
pkgdesc = A portable VPN client for Linux - Qt GUI only
pkgver = 2.2.1
- pkgrel = 5
+ pkgrel = 6
url = http://www.shrew.net/
arch = i686
arch = x86_64
@@ -17,9 +17,10 @@ pkgbase = shrew-vpn-client
source = http://www.shrew.net/download/ike/ike-2.2.1-release.tbz2
source = ikea.desktop
source = gui_only.patch
+ source = cmake-threadlib.patch
md5sums = 8fc14ac86771ee693d3950757c84f335
md5sums = 5b35a4246eb1b7bd4bfb6780c23d39f2
md5sums = eed8f22eedb29cad06abcfe8e513b028
+ md5sums = 4c823bae9e006cf7bfb11fa633a59837
pkgname = shrew-vpn-client
-
diff --git a/PKGBUILD b/PKGBUILD
index d7d4ddd9ef60..3e6f021d0af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=shrew-vpn-client
pkgver=2.2.1
-pkgrel=5
+pkgrel=6
pkgdesc="A portable VPN client for Linux - Qt GUI only"
arch=('i686' 'x86_64')
url="http://www.shrew.net/"
@@ -13,10 +13,17 @@ makedepends=('gcc' 'flex' 'libedit' 'bison' 'cmake')
conflicts=('shrew-vpn-client-alpha')
source=("http://www.shrew.net/download/ike/ike-$pkgver-release.tbz2"
'ikea.desktop'
- gui_only.patch)
+ gui_only.patch
+ 'cmake-threadlib.patch')
md5sums=('8fc14ac86771ee693d3950757c84f335'
'5b35a4246eb1b7bd4bfb6780c23d39f2'
- 'eed8f22eedb29cad06abcfe8e513b028')
+ 'eed8f22eedb29cad06abcfe8e513b028'
+ '4c823bae9e006cf7bfb11fa633a59837')
+
+prepare() {
+ cd "$srcdir/ike"
+ patch -p1 -i "$srcdir/cmake-threadlib.patch"
+}
build() {
cd "$srcdir/ike"
diff --git a/cmake-threadlib.patch b/cmake-threadlib.patch
new file mode 100644
index 000000000000..323e049ff90b
--- /dev/null
+++ b/cmake-threadlib.patch
@@ -0,0 +1,28 @@
+diff --unified --recursive --text --color package.orig/ike/CMakeLists.txt package.new/ike/CMakeLists.txt
+--- a/CMakeLists.txt 2022-04-04 14:41:54.512667837 -0500
++++ b/CMakeLists.txt 2022-04-04 14:42:13.302667617 -0500
+@@ -321,15 +321,15 @@
+
+ endif( NOT CMAKE_USE_PTHREADS_INIT )
+
+-if( NOT APPLE )
+-
+- check_library_exists(
+- ${CMAKE_THREAD_LIBS_INIT}
+- "pthread_mutex_timedlock"
+- ""
+- FUNC_LIB_TIMEDLOCK )
+-
+-endif( NOT APPLE )
++#if( NOT APPLE )
++#
++# check_library_exists(
++# ${CMAKE_THREAD_LIBS_INIT}
++# "pthread_mutex_timedlock"
++# ""
++# FUNC_LIB_TIMEDLOCK )
++#
++#endif( NOT APPLE )
+
+ if( FUNC_LIB_TIMEDLOCK )
+