summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67db3dc7f575..161c47f5ab60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
# Generated by mksrcinfo v8
-# Wed Jul 25 17:44:05 UTC 2018
+# Wed Jul 25 17:47:44 UTC 2018
pkgbase = shrinky-intro
- pkgdesc = Linux 4k intro skeleton
+ pkgdesc = Linux 4k intro skeleton (from dnload)
pkgver = 0.1
- pkgrel = 1
- url = http://github.org/xyproto/shrinky-intro/
+ pkgrel = 2
+ url = https://github.org/xyproto/shrinky-intro/
arch = x86_64
license = BSD
+ makedepends = git
makedepends = shrinky
depends = libgl
depends = sdl2
- optdepends = elfkickers: For stripping with sstrip
- optdepends = vulkan-devel: For Vulkan development
source = git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2679f8618981..3e726725a875 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,25 @@
pkgname=shrinky-intro
pkgver=0.1
-pkgrel=1
-pkgdesc='Linux 4k intro skeleton'
+pkgrel=2
+pkgdesc='Linux 4k intro skeleton (from dnload)'
arch=('x86_64')
-url="http://github.org/xyproto/shrinky-intro/"
+url='https://github.org/xyproto/shrinky-intro/'
license=('BSD')
-makedepends=('shrinky')
+makedepends=('git' 'shrinky')
depends=('libgl' 'sdl2')
-optdepends=('elfkickers: For stripping with sstrip'
- 'vulkan-devel: For Vulkan development')
-source=("git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244")
+#optdepends=('elfkickers: For stripping with sstrip'
+# 'vulkan-devel: For Vulkan development')
+source=('git+https://github.com/xyproto/shrinky-intro#commit=438ad8b197ff15fb561fe3a0b15d602486e90244')
md5sums=("SKIP")
build() {
- shrinky "$pkgname/main.cpp"
+ shrinky $pkgname/main.cpp
}
package() {
- cd "$pkgname"
- install -Dm755 main "$pkgdir/usr/bin/$pkgname"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 $pkgname/main "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim: ts=2 sw=2 et: