summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43e0a186743d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sia-daemon
+ pkgdesc = Blockchain-based marketplace for file storage
+ pkgver = v1.2.2
+ pkgrel = 1
+ url = https://sia.tech
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ source = https://github.com/NebulousLabs/Sia/releases/download/v1.2.2/Sia-v1.2.2-linux-amd64.zip
+ sha256sums = b11e4535510b3affe0820059226507d68463ddc8cf2c5f59fbe2ff9f8931055c
+
+pkgname = sia-daemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb5b5ebb1bbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Marcel O'Neil <marcel@marceloneil.com>
+
+pkgname=sia-daemon
+pkgver=v1.2.2
+pkgrel=1
+pkgdesc="Blockchain-based marketplace for file storage"
+arch=('x86_64')
+url="https://sia.tech"
+license=('MIT')
+depends=('glibc')
+source=("https://github.com/NebulousLabs/Sia/releases/download/${pkgver}/Sia-${pkgver}-linux-amd64.zip")
+sha256sums=('b11e4535510b3affe0820059226507d68463ddc8cf2c5f59fbe2ff9f8931055c')
+
+package() {
+ cd $srcdir/Sia-$pkgver-linux-amd64
+
+ install -Dm755 siac "${pkgdir}/usr/bin/siac"
+ install -Dm755 siad "${pkgdir}/usr/bin/siad"
+}