summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD46
-rw-r--r--sickchill-git.install12
-rw-r--r--sickchill.service3
-rw-r--r--sickchill.sysusers1
5 files changed, 41 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db5df343f4e9..44e6b39726e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
- pkgver = 2021.7.23.1.r0
+ pkgver = 2024.2.18.r0
pkgrel = 1
url = https://sickchill.github.io
install = sickchill-git.install
@@ -16,8 +16,8 @@ pkgbase = sickchill-git
source = sickchill.service
source = sickchill.sysusers
source = sickchill.tmpfiles
- sha256sums = ca6a73f7c2019ddda2b338eb63be560bf1a5d6ae5ceab969dc032c05b6d2d7b5
- sha256sums = 1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850
+ sha256sums = b417284472d804e634c0dcaac2876ca164ad9a485f947e0f05798d0ce1136d59
+ sha256sums = aaeb298c9717da8b28853ed15509fb8428d975ae49e8737ebcec15caab9f0978
sha256sums = 2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f
pkgname = sickchill-git
diff --git a/PKGBUILD b/PKGBUILD
index 11da10f86f2d..41f703d16609 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
# Maintainer: willemw <willemw12@gmail.com>
-# NOTE This "PIP install" package is similar to a VCS package:
-# it has a pkgver() function and a reinstall will update the package.
-# That is the only reason why this package ends on -git.
+# To install a specific SickChill release:
+# - comment out pkgver()
+# - set the release number in variable pkgver: pkgver=<release>
+# - set the release number at the end of the "pip install" line: change sickchill to sickchill==<release>
+
+# This "PIP install" package is similar to a VCS package:
+# it has a pkgver() function and a reinstall updates the package.
+# That is the only reason why this package ends on "-git".
pkgname=sickchill-git
-pkgver=2021.7.23.1.r0
+pkgver=2024.2.18.r0
pkgrel=1
-pkgdesc="Automatic video library manager for TV shows"
-arch=('any')
-url="https://sickchill.github.io"
-license=('GPL3')
-makedepends=('jq' 'python-virtualenv')
+pkgdesc='Automatic video library manager for TV shows'
+arch=(any)
+url=https://sickchill.github.io
+license=(GPL3)
+makedepends=(jq python-virtualenv)
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
'unrar: for RAR files')
-provides=(${pkgname%-git})
-conflicts=(${pkgname%-git})
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!strip')
install=$pkgname.install
-source=('sickchill.service'
- 'sickchill.sysusers'
- 'sickchill.tmpfiles')
-sha256sums=('ca6a73f7c2019ddda2b338eb63be560bf1a5d6ae5ceab969dc032c05b6d2d7b5'
- '1467f3613f5f25e678e373465dc09a28230f7cdf07af23875a0896a509c3b850'
+source=(sickchill.service
+ sickchill.sysusers
+ sickchill.tmpfiles)
+sha256sums=('b417284472d804e634c0dcaac2876ca164ad9a485f947e0f05798d0ce1136d59'
+ 'aaeb298c9717da8b28853ed15509fb8428d975ae49e8737ebcec15caab9f0978'
'2069f15e18fc7dd0f0f25b623f2067fc9028b1ca4122021a62364aa39914f88f')
pkgver() {
@@ -40,15 +45,14 @@ build() {
--default-timeout=60 --disable-pip-version-check --no-warn-script-location --progress-bar=off \
sickchill
- sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill.py
+ sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill
}
package() {
install -Dm644 sickchill.service -t "$pkgdir/usr/lib/systemd/system"
- install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
- install -Dm644 sickchill.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
+ install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
+ install -Dm644 sickchill.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
install -dm755 "$pkgdir/opt/sickchill"
- cp -a build "$pkgdir/opt/sickchill/app"
+ cp -a build "$pkgdir/opt/sickchill/app"
}
-
diff --git a/sickchill-git.install b/sickchill-git.install
index b52160d2ee2b..74a04ec3b969 100644
--- a/sickchill-git.install
+++ b/sickchill-git.install
@@ -1,8 +1,17 @@
+# Remove all program files, including files created or modified by SickChill
+_cleanup_app_files() {
+ rm -rf /opt/sickchill/app
+}
+
post_install() {
post_upgrade
echo "==> Start and enable sickchill.service. Then visit http://localhost:8081/"
}
+pre_upgrade() {
+ _cleanup_app_files
+}
+
post_upgrade() {
systemd-sysusers sickchill.conf
chown -R sickchill:sickchill /opt/sickchill/app
@@ -14,8 +23,7 @@ pre_remove() {
}
post_remove() {
- # Remove additional files created by the built-in updater
- rm -rf /opt/sickchill/app
+ _cleanup_app_files
echo "==> To delete the configuration files, run as root: rm -rf /opt/sickchill/data"
diff --git a/sickchill.service b/sickchill.service
index 385b031b1587..fb4dec3dca42 100644
--- a/sickchill.service
+++ b/sickchill.service
@@ -8,7 +8,8 @@ User=sickchill
Group=sickchill
Type=simple
-ExecStart=/opt/sickchill/app/bin/SickChill.py --quiet --nolaunch --datadir=/opt/sickchill/data
+#ExecStart=/var/lib/sickchill/app/bin/SickChill --quiet --nolaunch --datadir=/var/lib/sickchill/data
+ExecStart=/opt/sickchill/app/bin/SickChill --quiet --nolaunch --datadir=/opt/sickchill/data
[Install]
WantedBy=multi-user.target
diff --git a/sickchill.sysusers b/sickchill.sysusers
index e535bb2be54f..cb39976db281 100644
--- a/sickchill.sysusers
+++ b/sickchill.sysusers
@@ -1 +1,2 @@
+#u sickchill - "SickChill Daemon" /var/lib/sickchill
u sickchill - "SickChill Daemon" /opt/sickchill