summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD32
-rw-r--r--sickchill-git.install1
3 files changed, 13 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 663141669379..bbf2bb8ce981 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
- pkgver = 0.0.55.r0
+ pkgver = 0.0.56.r0
pkgrel = 1
url = https://sickchill.github.io
install = sickchill-git.install
arch = any
license = GPL3
- makedepends = python-virtualenv
- depends = nodejs
- depends = python-pip
- depends = python-pyopenssl
- depends = python-virtualenv
+ optdepends = libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename
optdepends = unrar: for RAR archives
provides = sickchill
conflicts = sickchill
diff --git a/PKGBUILD b/PKGBUILD
index 725484a165a7..78529ad5d5ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,14 @@
# That is the only reason why this package ends on -git.
pkgname=sickchill-git
-pkgver=0.0.55.r0
+pkgver=0.0.56.r0
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
url="https://sickchill.github.io"
license=('GPL3')
-depends=('nodejs' 'python-pip' 'python-pyopenssl' 'python-virtualenv')
-makedepends=('python-virtualenv')
-# 'deluge: supported torrent client'
-# 'qbittorrent: supported torrent client'
-# 'rtorrent: supported torrent client'
-# 'sabnzbd: supported NZB downloader'
-# 'transmission-cli: supported torrent client'
-#mediainfo
-optdepends=('unrar: for RAR archives')
+optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
+ 'unrar: for RAR archives')
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
options=('!strip')
@@ -31,21 +24,15 @@ md5sums=('309b8555af7b355f16a3ec784771f426'
'515f13e391105a716ef6763ba8533fc7')
pkgver() {
- pip search "${pkgname%-git}" | awk '$1 == "'${pkgname%-git}'" { gsub("[()]", ""); print $2 ".r0" }'
-}
-
-prepare() {
- rm -rf build
+ python -m venv pkgver
+ pkgver/bin/pip search "${pkgname%-git}" | awk '$1 == "'${pkgname%-git}'" { gsub("[()]", ""); print $2 ".r0" }'
}
build() {
- mkdir -p build
- cd build
+ python -m venv build
+ build/bin/pip install --quiet --quiet --isolated --no-warn-script-location --root=build --prefix=. sickchill
- virtualenv .
- ./bin/pip install --isolated --no-warn-script-location --root=. --prefix=. sickchill
-
- sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' bin/SickChill.py
+ sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill.py
}
package() {
@@ -53,7 +40,8 @@ package() {
install -Dm644 sickchill.sysusers "$pkgdir/usr/lib/sysusers.d/sickchill.conf"
install -Dm644 sickchill.tmpfile "$pkgdir/usr/lib/tmpfiles.d/sickchill.conf"
- install -dm755 "$pkgdir"/opt/sickchill/data
+ install -dm755 "$pkgdir/opt/sickchill/data"
+
cp -a build "$pkgdir/opt/sickchill/app"
warning "If the upgrade fails with \"error: failed to commit transaction (conflicting files)\", then uninstall first"
diff --git a/sickchill-git.install b/sickchill-git.install
index c6e6ded67562..44b3c3b1e207 100644
--- a/sickchill-git.install
+++ b/sickchill-git.install
@@ -11,6 +11,7 @@ post_upgrade() {
}
pre_remove() {
+ echo "==> Stopping sickchill.service..."
systemctl stop sickchill.service
}