summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbf2bb8ce981..2e540b9c44b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = sickchill-git
install = sickchill-git.install
arch = any
license = GPL3
+ makedepends = python-virtualenv
optdepends = libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename
optdepends = unrar: for RAR archives
provides = sickchill
diff --git a/PKGBUILD b/PKGBUILD
index 78529ad5d5ea..323ee00e6638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ pkgdesc="Automatic video library manager for TV shows"
arch=('any')
url="https://sickchill.github.io"
license=('GPL3')
+makedepends=('python-virtualenv')
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
'unrar: for RAR archives')
provides=(${pkgname%-git})
@@ -29,7 +30,8 @@ pkgver() {
}
build() {
- python -m venv build
+ #python -m venv build
+ virtualenv build
build/bin/pip install --quiet --quiet --isolated --no-warn-script-location --root=build --prefix=. sickchill
sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill.py