summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
-rw-r--r--sickchill-git.install12
3 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d5882233a20..6e60924125a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
- pkgver = 2021.5.10.1.r0
+ pkgver = 2021.6.16.r0
pkgrel = 1
url = https://sickchill.github.io
install = sickchill-git.install
@@ -21,4 +21,3 @@ pkgbase = sickchill-git
md5sums = 515f13e391105a716ef6763ba8533fc7
pkgname = sickchill-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c6a222d93f2b..f2829fedd493 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: willemw <willemw12@gmail.com>
# NOTE This "PIP install" package is similar to a VCS package:
-# it has a pkgver() function and to update do a reinstall.
+# it has a pkgver() function and a reinstall will update the package.
# That is the only reason why this package ends on -git.
pkgname=sickchill-git
-pkgver=2021.5.10.1.r0
+pkgver=2021.6.16.r0
pkgrel=1
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
@@ -31,13 +31,12 @@ pkgver() {
}
build() {
- set -x
#python -m venv build
- virtualenv --quiet build
- build/bin/pip install --isolated --no-warn-script-location --root=build --prefix=. --default-timeout=60 sickchill
+ export XDG_CACHE_HOME=cache/pip
+ VIRTUALENV_OVERRIDE_APP_DATA=cache/virtualenv virtualenv build
+ build/bin/pip install --isolated --no-warn-script-location --prefix=. --root=build --cache-dir=cache --default-timeout=60 --progress-bar=off sickchill
sed -i '1s|.*|#!/opt/sickchill/app/bin/python|' build/bin/SickChill.py
- set +x
}
package() {
diff --git a/sickchill-git.install b/sickchill-git.install
index 9faefc9e69ab..b2aac1beb1ba 100644
--- a/sickchill-git.install
+++ b/sickchill-git.install
@@ -1,15 +1,15 @@
post_install() {
- systemd-sysusers sickchill.conf
- systemd-tmpfiles --create sickchill.conf
-
- chown -R sickchill:sickchill /opt/sickchill/app
- chown sickchill:sickchill /opt/sickchill/data
+ post_upgrade
echo "==> Start and enable sickchill.service. Then visit http://localhost:8081/"
}
post_upgrade() {
- post_install "$1"
+ systemd-sysusers sickchill.conf
+ systemd-tmpfiles --create sickchill.conf
+
+ chown -R sickchill:sickchill /opt/sickchill/app
+ chown sickchill:sickchill /opt/sickchill/data
}
pre_remove() {