summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f80c9a58aae8..f0b8fe609d85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = sickchill-git
pkgdesc = Automatic video library manager for TV shows
pkgver = 2020.11.24.post1.r0
- pkgrel = 1
+ pkgrel = 2
url = https://sickchill.github.io
install = sickchill-git.install
arch = any
license = GPL3
+ makedepends = jq
makedepends = python-virtualenv
optdepends = libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename
optdepends = unrar: for RAR archives
diff --git a/PKGBUILD b/PKGBUILD
index 55b27d31b463..bd0faa19b7ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=sickchill-git
pkgver=2020.11.24.post1.r0
-pkgrel=1
+pkgrel=2
pkgdesc="Automatic video library manager for TV shows"
arch=('any')
url="https://sickchill.github.io"
license=('GPL3')
-makedepends=('python-virtualenv')
+makedepends=('jq' 'python-virtualenv')
optdepends=('libmediainfo: determine the resolution of MKV and AVI files with no resolution in the filename'
'unrar: for RAR archives')
provides=("${pkgname%-git}")
@@ -27,10 +27,8 @@ md5sums=('309b8555af7b355f16a3ec784771f426'
export PIP_DEFAULT_TIMEOUT=60
pkgver() {
- #python -m venv pkgver
- #pkgver/bin/pip search "${pkgname%-git}" | awk '$1 == "'${pkgname%-git}'" { gsub("[()]", ""); print $2 ".r0" }'
-
- curl -s "https://pypi.org/search/?q=${pkgname%-git}" | sed -n 's/.*package-snippet__version">\(.*\)<.*/\1.r0/p'
+ curl -s "https://pypi.org/pypi/${pkgname%-git}/json" | jq --raw-output --join-output '.info.version'
+ printf ".r0"
}
build() {