summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--segfault-and-install.patch33
-rw-r--r--siggen.install1
3 files changed, 27 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01b1ac64db09..f564cf8f4b84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=siggen
pkgver=2.3.10
-pkgrel=1
+pkgrel=2
pkgdesc="Curses based signal generator"
arch=('i686' 'x86_64')
url="http://www.comp.leeds.ac.uk/jj/linux/siggen.html"
@@ -15,7 +15,7 @@ install=("${pkgname}.install")
source=("http://www.comp.leeds.ac.uk/jj/linux/${pkgname}.tgz"
"segfault-and-install.patch")
sha256sums=('10f2749d144675c0faf37bffa276b49cbb2d44388a087928808acf5d0b0914fc'
- '1b316cba9663b90d1a8bfbe70d79a79c7304ad4f3b950b9a069ba43ec4fe64df')
+ 'be323506fc641c7057b31d48e9e66d7a0c6abc4c365d18b05061dd43d67b7b31')
build() {
# Apply patch to fix installation path and some segfaults
diff --git a/segfault-and-install.patch b/segfault-and-install.patch
index 680aee07df62..c3c814f91fcf 100644
--- a/segfault-and-install.patch
+++ b/segfault-and-install.patch
@@ -1,9 +1,15 @@
-siggen 2.3.10 patch by doragasu (2015). This patch fixes two things:
-1.- Allows to install siggen anywhere, overriding INSDIR and MANDIR.
-2.- Fixes some segfaults due to misc.c missing string.h include.
-diff -ruN siggen-2.3.10/Makefile siggen-2.3.10.work/Makefile
---- siggen-2.3.10/Makefile 2008-05-11 21:47:57.000000000 +0200
-+++ siggen-2.3.10.work/Makefile 2015-06-19 21:59:07.081129612 +0200
+diff -ruN siggen-2.3.10.orig/Makefile siggen-2.3.10/Makefile
+--- siggen-2.3.10.orig/Makefile 2008-05-11 21:47:57.000000000 +0200
++++ siggen-2.3.10/Makefile 2015-11-01 21:59:24.553305871 +0100
+@@ -9,7 +9,7 @@
+
+ # Edit PROGS to make the programs you want. You may wish to omit smix
+ # if you do not want yet another mixer program.
+-PROGS = tones sgen swgen siggen sweepgen fsynth soundinfo smix
++PROGS = tones sgen_ swgen siggen sweepgen fsynth soundinfo smix
+
+ #
+ TEXTS = tones.txt sgen.txt swgen.txt siggen.txt sweepgen.txt soundinfo.txt smix.txt fsynth.txt siggen.conf.txt
@@ -28,8 +28,8 @@
#
srcdir = .
@@ -25,9 +31,18 @@ diff -ruN siggen-2.3.10/Makefile siggen-2.3.10.work/Makefile
@echo "Copying $(PROGS) to $(INSDIR)"
@cp -p $(PROGS) $(INSDIR)
@for n in $(PROGS) ; do \
-diff -ruN siggen-2.3.10/misc.c siggen-2.3.10.work/misc.c
---- siggen-2.3.10/misc.c 2008-05-11 22:55:16.000000000 +0200
-+++ siggen-2.3.10.work/misc.c 2015-06-21 18:09:07.299554288 +0200
+@@ -115,7 +118,7 @@
+ soundinfo: soundinfo.o
+ $(CC) $@.o -o $@
+
+-sgen: $(SGEN)
++sgen_: $(SGEN)
+ $(CC) $(SGEN) -lm -o $@
+
+ swgen: $(SWGEN)
+diff -ruN siggen-2.3.10.orig/misc.c siggen-2.3.10/misc.c
+--- siggen-2.3.10.orig/misc.c 2008-05-11 22:55:16.000000000 +0200
++++ siggen-2.3.10/misc.c 2015-11-01 21:58:09.480189829 +0100
@@ -27,6 +27,7 @@
#include <sys/types.h>
#include <unistd.h>
diff --git a/siggen.install b/siggen.install
index 393bc8a27abc..bfa43c2b8394 100644
--- a/siggen.install
+++ b/siggen.install
@@ -1,4 +1,5 @@
post_install() {
+ echo 'Warning: sgen has been renamed to sgen_, because it conflicts with Mono Xml Serializer Generator Tool.'
echo 'Warning: if binaries in this package fail, complaining they cannot find /dev/dsp, you can try loading snd-pcm-oss module as follows (with root privileges):
# modprobe snd-pcm-oss'