summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
-rwxr-xr-xsigil.desktop11
-rw-r--r--sigil.pngbin0 -> 59479 bytes
-rwxr-xr-xsigil_compat.desktop11
6 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cbd3d135110
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sigil-wad
+ pkgdesc = Free SIGIL Megawad v1.0, the unofficial 5th episode of the original 1993 DOOM by John Romero, celebrating its 25th anniversary. Contains nine single-player and nine deathmatch levels. Requires original DOOM.WAD or Ultimate DOOM.WAD to play. Versions with Buckethead or THORR soundtracks available at .
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://romero.com/sigil
+ arch = any
+ license = custom
+ makedepends = unzip
+ source = https://romero.com/s/SIGIL_V1_0.zip
+ source = sigil.png
+ source = sigil.desktop
+ source = sigil_compat.desktop
+ sha256sums = 3e2a3945d8cfd5a0a69ccc9b1ea4c2a0ba19efcbbd367d63832586697bc70d88
+ sha256sums = 43511e839b9b852169f4d18d69e88ec9ac92eb05f0382fd4cb7404f4ad9ff0ea
+ sha256sums = 37ea66ee77f07b64ec8646ee6ca761be6c1d63719ec3e7106abc902c97391abd
+ sha256sums = 7d5c26f36b43a90abf76d22da762303aff166bd85d5e3d141dcaa09bbc348523
+
+pkgname = sigil-wad
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..34330036fb4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.zip
+*.pkg.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c6f01d746fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Yakov Till <yakov.till at gmail dot com>
+
+
+pkgname=sigil-wad
+pkgver=1.0
+pkgrel=1
+pkgdesc="Free Megawad of SIGIL, the unofficial 5th episode of the original 1993 DOOM by John Romero, celebrating its 25th anniversary. Contains nine single-player and nine deathmatch levels. Requires original DOOM.WAD or Ultimate DOOM.WAD to play. Versions with Buckethead or THORR soundtracks available at ${url}."
+arch=('any')
+url="https://romero.com/sigil"
+license=('custom')
+makedepends=('unzip')
+_filever="${pkgver//./_}"
+source=("https://romero.com/s/SIGIL_V${_filever}.zip"
+ "sigil.png"
+ "sigil.desktop"
+ "sigil_compat.desktop")
+
+sha256sums=('3e2a3945d8cfd5a0a69ccc9b1ea4c2a0ba19efcbbd367d63832586697bc70d88'
+ '43511e839b9b852169f4d18d69e88ec9ac92eb05f0382fd4cb7404f4ad9ff0ea'
+ '37ea66ee77f07b64ec8646ee6ca761be6c1d63719ec3e7106abc902c97391abd'
+ '7d5c26f36b43a90abf76d22da762303aff166bd85d5e3d141dcaa09bbc348523')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/doom"
+ install -Dm644 "SIGIL_README_V${_filever}.txt" "$pkgdir/usr/share/doc/$pkgname/instructions.txt"
+ install -Dm644 "SIGIL_V${_filever}.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 "SIGIL_V${_filever}.wad" "$pkgdir/usr/share/games/sigil/sigil.wad"
+ install -Dm644 "SIGIL_COMPAT_V${_filever}.wad" "$pkgdir/usr/share/games/sigil/sigil_compat.wad"
+ ln -s /usr/share/games/sigil/sigil.wad "$pkgdir/usr/share/doom/sigil.wad"
+ ln -s /usr/share/games/sigil/sigil_compat.wad "$pkgdir/usr/share/doom/sigil_compat.wad"
+
+ cd "$srcdir"
+ install -Dm644 "sigil.png" "$pkgdir/usr/share/pixmaps/sigil.png"
+ install -Dm644 "sigil.desktop" "$pkgdir/usr/share/applications/sigil.desktop"
+ install -Dm644 "sigil_compat.desktop" "$pkgdir/usr/share/applications/sigil_compat.desktop"
+}
diff --git a/sigil.desktop b/sigil.desktop
new file mode 100755
index 000000000000..cbb98be3ac79
--- /dev/null
+++ b/sigil.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=SIGIL
+GenericName=SIGIL Megawad
+Comment=Play SIGIL, the unofficial 5th episode of Doom
+Type=Application
+Icon=sigil
+Exec=xdg-open /usr/share/doom/sigil.wad
+MimeType=application/x-doom-wad;
+Keywords=Doom;Game;
+Terminal=false
+Categories=Game;ActionGame;
diff --git a/sigil.png b/sigil.png
new file mode 100644
index 000000000000..96c0394f9177
--- /dev/null
+++ b/sigil.png
Binary files differ
diff --git a/sigil_compat.desktop b/sigil_compat.desktop
new file mode 100755
index 000000000000..8395515382de
--- /dev/null
+++ b/sigil_compat.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=SIGIL (Compatibility Mode)
+GenericName=SIGIL Megawad Compatibility Mode
+Comment=Play SIGIL in compatibility mode, suitable for classic Doom engines
+Type=Application
+Icon=sigil
+Exec=xdg-open /usr/share/doom/sigil_compat.wad
+MimeType=application/x-doom-wad;
+Keywords=Doom;Game;
+Terminal=false
+Categories=Game;ActionGame;