summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--expire-from-source-date-epoch.patch10
2 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f8f07d49d27..c9295c87b334 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=signal-desktop-beta
_pkgname=Signal-Desktop
pkgver=5.18.0beta1
-pkgrel=1
+pkgrel=2
pkgdesc='Signal Private Messenger for Linux - Beta version.'
license=('GPL3')
conflicts=('signal-desktop-beta-bin')
@@ -24,7 +24,7 @@ source=(
)
sha512sums=('3b1b336be1d9e67f0a64f2985f048a0318474e99dbda3b5e18650f005a7afec27d90dd64bb5b943707a1acdd99ffffe9a8eec81a851e627d9c4b773787a75f8f'
'b8d329605183dde34bb269e07cf27f6a543b3dce07e424ffbdd53c9bed69bc02f44c402aa25e70b20dc7bf7538fbfc00576864b5c6d40acc7c1b6d945b030f13'
- '6673066172d6c367961f3e2d762dd483e51a9f733d52e27d0569b333ad397375fd41d61b8a414b8c9e8dbba560a6c710678b3d105f8d285cb94d70561368d5a2'
+ '2cb355e8007f0ce3ab9a61fe85d86763768667ce4c7b97a33422070235af3b1b5eafbdee03aaa114d3bf1f26cfcf19b0186c3c8b5833a364bfd07be3dba2d9cb'
'457c1bd044f4e17810a7f1b284ca38809a0c1f8fed4bdb52184a169e2996e683c4c96c1cc86a013feb7b8833557245397decdcec01dbc82bb2b12b0d80424e25')
prepare() {
diff --git a/expire-from-source-date-epoch.patch b/expire-from-source-date-epoch.patch
index d29c79835179..a4d698623ba2 100644
--- a/expire-from-source-date-epoch.patch
+++ b/expire-from-source-date-epoch.patch
@@ -1,6 +1,6 @@
---- a/Gruntfile.js
-+++ b/Gruntfile.js
-@@ -203,9 +203,7 @@ module.exports = grunt => {
+--- a/Gruntfile.js 2021-09-23 04:25:41.069024593 -0500
++++ b/Gruntfile.js 2021-09-23 04:26:20.878766965 -0500
+@@ -171,9 +171,7 @@
});
grunt.registerTask('getExpireTime', () => {
@@ -8,6 +8,6 @@
- const gitinfo = grunt.config.get('gitinfo');
- const committed = gitinfo.local.branch.current.lastCommitTime;
+ const committed = parseInt(process.env.SOURCE_DATE_EPOCH, 10) * 1000;
- const time = Date.parse(committed) + 1000 * 60 * 60 * 24 * 90;
+ const buildCreation = Date.parse(committed);
+ const buildExpiration = buildCreation + 1000 * 60 * 60 * 24 * 90;
grunt.file.write(
- 'config/local-production.json',