summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1d8cebf122e..80e31654ae70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ pkgrel='3'
arch=('i386' 'x86_64')
url='http://www.sile-typesetter.org/'
license=('MIT')
-source=("https://github.com/simoncozens/sile/archive/v${pkgver}.tar.gz"
- "https://github.com/simoncozens/libtexpdf/archive/${_libtexpdf_ver}.tar.gz")
+source=("https://github.com/simoncozens/sile/archive/v$pkgver.tar.gz"
+ "https://github.com/simoncozens/libtexpdf/archive/$_libtexpdf_ver.tar.gz")
sha512sums=('3d041f3e014f2d55f878f535d7ffd5b271b5aa2dc5f74e68261f1f1cdbdd18d7901c77a92a7701a91f7eefae71aa550167b441ced740dc4e459d29bcd8cc9e5e'
'da8a3d663385138fd2ba4306e190ea5294631f622cce4592198d75cd76109a31c2db24ede95e6adad98f29f952d3a1656a46b8ec9448f6146689f1b5763dd004')
@@ -22,32 +22,32 @@ depends=('lua-lpeg'
'harfbuzz>=1.2.6')
prepare () {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
rm -rf libtexpdf
- cp -a ../libtexpdf-${_libtexpdf_ver} libtexpdf
+ cp -a ../libtexpdf-"$_libtexpdf_ver" libtexpdf
autoreconf --install
(cd libtexpdf && autoreconf -I m4)
sed 's/rm -f core/rm -f/' -i configure
}
build () {
- cd "${pkgname}-${pkgver}"
+ cd "$pkgname-$pkgver"
./configure --prefix=/usr
make
}
package () {
- cd "${pkgname}-${pkgver}"
- make install DESTDIR="${pkgdir}/"
+ cd "$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir/"
# Documentation and examples
for file in README.md ROADMAP documentation/sile.pdf ; do
- install -Dm644 "${file}" \
- "${pkgdir}/usr/share/doc/${pkgname}/${file}"
+ install -Dm644 "$file" \
+ "$pkgdir/usr/share/doc/$pkgname/$file"
done
- cp -ar examples "${pkgdir}/usr/share/doc/${pkgname}"
+ cp -ar examples "$pkgdir/usr/share/doc/$pkgname"
# License
install -Dm644 LICENSE \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}