summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0863419967ed..d113eb56bf83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = silkaj
pkgdesc = Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies
- pkgver = 0.8.1
+ pkgver = 0.10.0
pkgrel = 1
url = https://git.duniter.org/clients/python/silkaj
arch = any
license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- depends = python-setuptools
- depends = python-dephell
depends = python-click
depends = python-ipaddress
depends = python-texttable
@@ -16,7 +17,7 @@ pkgbase = silkaj
depends = python-duniterpy
depends = python-pypeg2
depends = python-pylibscrypt
- source = https://git.duniter.org/clients/python/silkaj/-/archive/v0.8.1/silkaj-v0.8.1.tar.gz
- sha512sums = 0ced0aa81da2b56f5178de13c2bbd10923acaf2765b5924493b9169ec5080c9dbf1ae419bcb8837955fbfc86c7f4b22d8365b36351101622b196d4009e6231e5
+ source = https://git.duniter.org/clients/python/silkaj/-/archive/v0.10.0/silkaj-v0.10.0.tar.gz
+ sha512sums = 1e326f1d7b4b916e050615c29b27aaeb96d67199b188f5b164ef3059a6c61aa37afc60533e033ece769981850f6e086e3c09a313d83d565c9eb21054cccf3754
pkgname = silkaj
diff --git a/PKGBUILD b/PKGBUILD
index 5734e86f30c7..3e78b5198d91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: neodarz <neodarz at neodarz dot net>
+# Maintainer: brodokk <brodokk at brodokk dot space>
pkgname=silkaj
-pkgver=0.8.1
+pkgver=0.10.0
pkgrel=1
pkgdesc="Powerfull, lightweight, and multi-platform command line client written with Python for Duniter’s currencies"
@@ -10,18 +10,17 @@ url='https://git.duniter.org/clients/python/silkaj'
arch=('any')
license=('GPL3')
-depends=('python' 'python-setuptools' 'python-dephell' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl'
+depends=('python' 'python-click' 'python-ipaddress' 'python-texttable' 'python-tabulate' 'python-pynacl'
'python-duniterpy' 'python-pypeg2' 'python-pylibscrypt')
+makedepends=(python-build python-installer python-wheel)
source=("https://git.duniter.org/clients/python/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha512sums=('0ced0aa81da2b56f5178de13c2bbd10923acaf2765b5924493b9169ec5080c9dbf1ae419bcb8837955fbfc86c7f4b22d8365b36351101622b196d4009e6231e5')
+sha512sums=('1e326f1d7b4b916e050615c29b27aaeb96d67199b188f5b164ef3059a6c61aa37afc60533e033ece769981850f6e086e3c09a313d83d565c9eb21054cccf3754')
-prepare() {
- cd "$pkgname-v$pkgver"
- dephell deps convert --from pyproject.toml --to setup.py
+build() {
+ python -m build --wheel --no-isolation
}
package() {
- cd "$pkgname-v$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}