summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b2205e6b42bb..6dec8160c394 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
#
-# SimGrid: Grid and Cloud Simulator
+# SimGrid: Framework for the simulation of distributed applications
#
-# Maintainer: Javier J. Salmeron-Garcia <javsalgar@gmail.com>
+# Maintainer: Millian Poquet <millian.poquet@gmail.com>
pkgname=simgrid
-pkgver=3.11.1
+pkgver=3.22.2
pkgrel=1
-pkgdesc='Grid and Cloud Simulator (Stable Version)'
+pkgdesc='A scientific instrument to study the behavior of large-scale distributed systems such as Grids, Clouds, HPC or P2P systems.'
arch=('i686' 'x86_64')
-url='http://simgrid.gforge.inria.fr/index.html'
-license=('GPL')
-source=('http://gforge.inria.fr/frs/download.php/file/33686/SimGrid-3.11.1.tar.gz')
+url='https://simgrid.org/'
+license=('LGPL')
+source=('https://framagit.org/simgrid/simgrid/uploads/b086147968e111e7b7d7e27e8c4b11c5/SimGrid-3.22.tar.gz')
depends=('boost')
makedepends=('cmake')
-md5sums=('SKIP')
+md5sums=('d5c229b2b53b9bb9a1136d5720db7e47')
pkgver() {
- echo 3.11.1
+ echo 3.22.2
}
-
package() {
- mkdir -p $pkgdir/opt/simgrid
- cd $srcdir/SimGrid-3.11/
- cmake -DCMAKE_INSTALL_PREFIX=$pkgdir/opt/simgrid .
- make
- make install
+ mkdir -p $pkgdir/opt/simgrid
+ cd $srcdir/SimGrid-3.22/
+ cmake -DCMAKE_INSTALL_PREFIX=$pkgdir/opt/simgrid .
+ make
+ make install
}