summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--Makefile28
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34c00f295bc1..d14b96db8598 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by mksrcinfo v8
-# Sun Jan 1 17:19:08 UTC 2017
pkgbase = simple-mtpfs
pkgdesc = A FUSE filesystem that supports reading/writing from MTP devices
- pkgver = 0.3.0
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/phatina/simple-mtpfs/
arch = i686
arch = x86_64
license = GPL2
+ makedepends = autoconf-archive
depends = libmtp
depends = fuse
depends = gcc-libs
- source = https://github.com/phatina/simple-mtpfs/archive/simple-mtpfs-0.3.0.tar.gz
- sha1sums = 9bbb315a4cc1020cdffbfea969dbd3c7a364c42d
+ source = simple-mtpfs-0.4.0.tar.gz::https://github.com/phatina/simple-mtpfs/archive/v0.4.0.tar.gz
+ sha256sums = 1d011df3fa09ad0a5c09d48d84c03e6cddf86390af9eb4e0c178193f32f0e2fc
pkgname = simple-mtpfs
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..8a02706c1167
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+all: clean build git install
+
+clean:
+ rm -r src pkg || true
+
+geninteg:
+ sed -i '/.*sums=(/,$$d' PKGBUILD
+ makepkg --geninteg >> PKGBUILD
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+makepkg:
+ makepkg -s
+
+build: geninteg srcinfo makepkg
+
+git: git_add git_commit
+
+git_add:
+ git add PKGBUILD .SRCINFO
+
+git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+git_commit:
+ git commit -m "Update to ${VERSION}"
+
+install:
+ makepkg --install
diff --git a/PKGBUILD b/PKGBUILD
index f391f44a1c7c..56619bfaa82a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
# Maintainer: goetzc
# Contributor: Dan Liew <dan at su-root dot co dot uk>
pkgname=simple-mtpfs
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="A FUSE filesystem that supports reading/writing from MTP devices"
arch=('i686' 'x86_64')
url="https://github.com/phatina/simple-mtpfs/"
license=('GPL2')
+makedepends=('autoconf-archive')
depends=('libmtp' 'fuse' 'gcc-libs')
-source=(https://github.com/phatina/simple-mtpfs/archive/$pkgname-$pkgver.tar.gz)
-sha1sums=('9bbb315a4cc1020cdffbfea969dbd3c7a364c42d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/phatina/$pkgname/archive/v$pkgver.tar.gz")
build() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
- if [[ ! -e "./configure" ]]; then
- ./autogen.sh
- ./configure --prefix=/usr
- else
- ./config.status
- fi
+ cd "$srcdir/$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
+
+sha256sums=('1d011df3fa09ad0a5c09d48d84c03e6cddf86390af9eb4e0c178193f32f0e2fc')