summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD58
-rw-r--r--Rlib.patch35
-rw-r--r--lua51.patch68
-rw-r--r--python-package.patch14
5 files changed, 139 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7690ab19478d..cd485b7e631b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,43 @@
# Generated by mksrcinfo v8
-# Sat Jul 2 16:27:33 UTC 2016
+# Sat Jul 16 08:00:54 UTC 2016
pkgbase = simpleitk
pkgdesc = A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages.
- pkgver = 0.9.1
+ pkgver = 0.10rc1
pkgrel = 3
url = http://www.simpleitk.org/
arch = i686
arch = x86_64
license = Apache
makedepends = cmake
+ makedepends = clang
makedepends = git
+ makedepends = lua51
makedepends = mono
makedepends = python
makedepends = python-pip
makedepends = python-virtualenv
+ makedepends = python-numpy
makedepends = r
makedepends = ruby
makedepends = swig
makedepends = tcl
makedepends = tk
+ depends = gcc-libs
depends = insight-toolkit
+ optdepends = lua51: Lua bindings
optdepends = mono: C# bindings
optdepends = python: Python bindings
+ optdepends = python-numpy: Python bindings
optdepends = r: R bindings
optdepends = ruby: Ruby bindings
optdepends = tcl: Tcl/TK bindings
optdepends = tk: Tcl/TK bindings
- source = https://sourceforge.net/projects/simpleitk/files/SimpleITK/0.9.1/Source/SimpleITK-0.9.1.tar.xz
- source = python-package.patch
+ source = git+https://github.com/SimpleITK/SimpleITK#tag=v0.10rc1
source = Rlib.patch
- source = cthead1.png::http://midas3.kitware.com/midas/api/rest?method=midas.bitstream.download&checksum=b23198c9e44a48edfd5b83f075eb455c&algorithm=md5
- source = cthead1-Float.mha::http://midas3.kitware.com/midas/api/rest?method=midas.bitstream.download&checksum=25de5707b18c0c684fd5fa30351bf787&algorithm=md5
- md5sums = 3b759cf21b89e213343ac6a4e616cd45
- md5sums = 1c97647461d932ca2e672606d1687f77
- md5sums = 3b6569561ed5047f3232b4f96ae98d74
- md5sums = b23198c9e44a48edfd5b83f075eb455c
- md5sums = 25de5707b18c0c684fd5fa30351bf787
+ source = lua51.patch
+ md5sums = SKIP
+ md5sums = 2888336abcbb122a49cb5817ac98f36c
+ md5sums = 89cd23ce562229b3b2b6301aee18fced
pkgname = simpleitk
diff --git a/PKGBUILD b/PKGBUILD
index 94d67b352bfc..05b7b5db4f87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,50 @@
# Maintainer: Yen Chi Hsuan <yan12125 at gmail.com>
_pkgname=SimpleITK
pkgname=simpleitk
-pkgver=0.9.1
+pkgver=0.10rc1
+_pypkgver=0.10.0rc1
pkgrel=3
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
license=('Apache')
-depends=('insight-toolkit')
-makedepends=('cmake' 'git' 'mono' 'python' 'python-pip' 'python-virtualenv' 'r' 'ruby' 'swig' 'tcl' 'tk')
+depends=('gcc-libs' 'insight-toolkit')
+makedepends=('cmake' 'clang' 'git' 'lua51' 'mono' 'python' 'python-pip' 'python-virtualenv' 'python-numpy' 'r' 'ruby' 'swig' 'tcl' 'tk')
optdepends=(
+ 'lua51: Lua bindings'
'mono: C# bindings'
'python: Python bindings'
+ 'python-numpy: Python bindings'
'r: R bindings'
'ruby: Ruby bindings'
'tcl: Tcl/TK bindings'
'tk: Tcl/TK bindings'
)
source=(
- "https://sourceforge.net/projects/$pkgname/files/$_pkgname/$pkgver/Source/$_pkgname-$pkgver.tar.xz"
- 'python-package.patch'
+ "git+https://github.com/$_pkgname/$_pkgname#tag=v$pkgver"
'Rlib.patch'
- "cthead1.png"::"http://midas3.kitware.com/midas/api/rest?method=midas.bitstream.download&checksum=b23198c9e44a48edfd5b83f075eb455c&algorithm=md5"
- "cthead1-Float.mha"::"http://midas3.kitware.com/midas/api/rest?method=midas.bitstream.download&checksum=25de5707b18c0c684fd5fa30351bf787&algorithm=md5"
+ 'lua51.patch'
)
-md5sums=('3b759cf21b89e213343ac6a4e616cd45'
- '1c97647461d932ca2e672606d1687f77'
- '3b6569561ed5047f3232b4f96ae98d74'
- 'b23198c9e44a48edfd5b83f075eb455c'
- '25de5707b18c0c684fd5fa30351bf787')
+md5sums=('SKIP'
+ '2888336abcbb122a49cb5817ac98f36c'
+ '89cd23ce562229b3b2b6301aee18fced')
prepare() {
- cd "$_pkgname-$pkgver"
+ cd "$_pkgname"
- mkdir -p build/ExternalData/Testing/Data/Input/
+ mkdir -p build
- cp ../{cthead1.png,cthead1-Float.mha} build/ExternalData/Testing/Data/Input/
-
- patch -Np1 -i ../python-package.patch
patch -Np1 -i ../Rlib.patch
+ patch -Np1 -i ../lua51.patch
}
build() {
- cd "$_pkgname-$pkgver/build"
+ cd "$_pkgname/build"
+
+ export CC=clang
+ export CXX=clang++
+ export CXXFLAGS="-std=c++11 $CXXFLAGS"
+ export CPP="clang -E"
# TODO: Java binding is broken with swig 3.0.9 and openjdk8
cmake \
@@ -59,20 +61,26 @@ build() {
}
package() {
- _builddir="$srcdir/$_pkgname-$pkgver/build"
+ _builddir="$srcdir/$_pkgname/build"
cd $_builddir
+ export CC=clang
+ export CXX=clang++
+ export CXXFLAGS="-std=c++11 $CXXFLAGS"
+ export CPP="clang -E"
+
make DESTDIR="$pkgdir/" install
pip install --root="$pkgdir/" --ignore-installed \
- "$_builddir/Wrapping/dist/$_pkgname-$pkgver-"*"-linux_$CARCH.whl"
+ "$_builddir/Wrapping/Python/dist/$_pkgname-$_pypkgver"*"-linux_$CARCH.whl"
- install -Dm755 "$_builddir/bin/SimpleITKLua" "$pkgdir/usr/bin/SimpleITKLua"
- install -Dm755 "$_builddir/bin/SimpleITKTclsh" "$pkgdir/usr/bin/SimpleITKTclsh"
- install -Dm755 "$_builddir/Wrapping/CSharpBinaries/libSimpleITKCSharpNative.so" "$pkgdir/usr/lib/libSimpleITKCSharpNative.so"
- install -Dm755 "$_builddir/Wrapping/CSharpBinaries/SimpleITKCSharpManaged.dll" "$pkgdir/usr/lib/SimpleITKCSharpManaged.dll"
+ install -d -Dm755 "$pkgdir/usr/lib/lua/5.1/"
+ install -Dm755 "$_builddir/Wrapping/Lua/lib/$_pkgname.so" "$pkgdir/usr/lib/lua/5.1/$_pkgname.so"
+ install -Dm755 "$_builddir/Wrapping/Tcl/bin/SimpleITKTclsh" "$pkgdir/usr/bin/SimpleITKTclsh"
+ install -Dm755 "$_builddir/Wrapping/CSharp/CSharpBinaries/libSimpleITKCSharpNative.so" "$pkgdir/usr/lib/libSimpleITKCSharpNative.so"
+ install -Dm755 "$_builddir/Wrapping/CSharp/CSharpBinaries/SimpleITKCSharpManaged.dll" "$pkgdir/usr/lib/SimpleITKCSharpManaged.dll"
install -d -Dm755 "$pkgdir/usr/lib/R/library/"
- cp -dr --no-preserve=ownership "$_builddir/Wrapping/Rpackaging/$_pkgname" "$pkgdir/usr/lib/R/library/"
+ cp -dr --no-preserve=ownership "$_builddir/Wrapping/R/Packaging/$_pkgname" "$pkgdir/usr/lib/R/library/"
}
diff --git a/Rlib.patch b/Rlib.patch
index 14fd50a90c31..ea43763821c0 100644
--- a/Rlib.patch
+++ b/Rlib.patch
@@ -1,11 +1,26 @@
---- SimpleITK-0.9.1/Wrapping/CMakeLists.txt 2016-06-19 05:59:04.985450567 +0800
-+++ SimpleITK-0.9.1/Wrapping/CMakeLists.txt 2016-06-19 06:00:35.875447944 +0800
-@@ -443,7 +443,7 @@
- COMMAND ${CMAKE_COMMAND} -E copy ${SimpleITK_BINARY_DIR}/ExternalData/Testing/Data/Input/cthead1.png ${CMAKE_CURRENT_BINARY_DIR}/Rpackaging/SimpleITK/data/
- COMMAND ${CMAKE_COMMAND} -E copy ${SimpleITK_BINARY_DIR}/ExternalData/Testing/Data/Input/cthead1-Float.mha ${CMAKE_CURRENT_BINARY_DIR}/Rpackaging/SimpleITK/data/
- # install for running tests and create binary package
-- COMMAND ${R_COMMAND} CMD INSTALL --build ${CMAKE_CURRENT_BINARY_DIR}/Rpackaging/SimpleITK --library=${CMAKE_CURRENT_BINARY_DIR}/RLib
-+ COMMAND ${CMAKE_COMMAND} -E env "LD_LIBRARY_PATH=${CMAKE_BINARY_DIR}/lib" ${R_COMMAND} CMD INSTALL --build ${CMAKE_CURRENT_BINARY_DIR}/Rpackaging/SimpleITK --library=${CMAKE_CURRENT_BINARY_DIR}/RLib
+diff --git a/Wrapping/R/CMakeLists.txt b/Wrapping/R/CMakeLists.txt
+index 87753ad..4740cf2 100644
+--- a/Wrapping/R/CMakeLists.txt
++++ b/Wrapping/R/CMakeLists.txt
+@@ -91,6 +91,6 @@ add_custom_command( TARGET ${SWIG_MODULE_SimpleITK_TARGET_NAME}
+ COMMAND ${CMAKE_COMMAND} -E make_directory ${CMAKE_CURRENT_BINARY_DIR}/R_libs
+ COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_BINARY_DIR}/SimpleITK.R ${CMAKE_CURRENT_BINARY_DIR}/Packaging/SimpleITK/R/
+ # install for running tests and create binary package
+- COMMAND ${R_COMMAND} CMD INSTALL --build ${CMAKE_CURRENT_BINARY_DIR}/Packaging/SimpleITK --library=${CMAKE_CURRENT_BINARY_DIR}/R_libs
++ COMMAND ${CMAKE_COMMAND} -E env "LD_LIBRARY_PATH=${CMAKE_BINARY_DIR}/lib" ${R_COMMAND} CMD INSTALL --build ${CMAKE_CURRENT_BINARY_DIR}/Packaging/SimpleITK --library=${CMAKE_CURRENT_BINARY_DIR}/R_libs
+ COMMENT "Installing R package for testing and building binary version for distribution"
+ )
+diff --git a/Wrapping/R/SimpleITK.i b/Wrapping/R/SimpleITK.i
+index b6688db..e034959 100644
+--- a/Wrapping/R/SimpleITK.i
++++ b/Wrapping/R/SimpleITK.i
+@@ -1,3 +1,9 @@
++%begin %{
++#define NO_C_HEADERS
++#include <cstdio>
++#include <cstddef>
++%}
++
+ %include SimpleITK_Common.i
- COMMENT "Installing R package for testing and building binary version for distribution"
- )
+ %include "sitkRCommand.h"
diff --git a/lua51.patch b/lua51.patch
new file mode 100644
index 000000000000..1c3a7e13beb6
--- /dev/null
+++ b/lua51.patch
@@ -0,0 +1,68 @@
+--- a/CMake/FindLuaInterp.cmake 2016-07-15 02:29:39.418795763 +0800
++++ b/CMake/FindLuaInterp.cmake 2016-07-15 02:29:45.812129311 +0800
+@@ -11,7 +11,7 @@
+ # LUA_EXECUTABLE_VERSION_STRING - version of lua found
+
+ find_program(LUA_EXECUTABLE
+- NAMES lua
++ NAMES lua5.1 lua
+ )
+
+ if(LUA_EXECUTABLE)
+--- a/Wrapping/Lua/CMakeLists.txt 2016-07-15 02:21:14.748778896 +0800
++++ Wrapping/Lua/CMakeLists.txt.orig 2016-07-15 02:20:55.322111581 +0800
+@@ -5,14 +5,7 @@
+ include(../../CMake/sitkProjectLanguageCommon.cmake)
+
+
+-if (CMAKE_VERSION VERSION_LESS "3")
+- find_package ( Lua51 ${_QUIET} )
+- if ( NOT LUA_FOUND )
+- find_package ( Lua50 ${_QUIET} )
+- endif()
+-else()
+- find_package ( Lua ${_QUIET} )
+-endif()
++find_package ( Lua51 ${_QUIET} )
+
+ set( LUA_ADDITIONAL_LIBRARIES "" CACHE STRING "Additional libraries which may be needed for lua executable such as readline.")
+ mark_as_advanced( LUA_ADDITIONAL_LIBRARIES )
+--- a/CMake/sitkGenerateFilterSource.cmake 2016-07-15 04:16:21.529009726 +0800
++++ b/CMake/sitkGenerateFilterSource.cmake 2016-07-15 04:16:41.519010392 +0800
+@@ -2,16 +2,8 @@
+ # Find a Lua executable
+ #
+ if ( NOT SITK_LUA_EXECUTABLE )
+- set ( SAVE_LUA_EXECUTABLE ${LUA_EXECUTABLE} )
+-
+ find_package( LuaInterp REQUIRED 5.1 )
+ set( SITK_LUA_EXECUTABLE ${LUA_EXECUTABLE} CACHE PATH "Lua executable used for code generation." )
+-
+- if (DEFINED SAVE_LUA_EXECUTABLE)
+- set( LUA_EXECUTABLE ${SAVE_LUA_EXECUTABLE} CACHE )
+- else()
+- unset( LUA_EXECUTABLE CACHE )
+- endif()
+ endif()
+
+ # Get the Lua version
+--- a/CMake/sitkLanguageOptions.cmake 2016-07-15 17:56:50.830654990 +0800
++++ b/CMake/sitkLanguageOptions.cmake 2016-07-15 17:57:23.547322749 +0800
+@@ -31,15 +31,8 @@
+ # Setup the option for each language
+ #
+ set_QUIET( WRAP_LUA )
+-if (CMAKE_VERSION VERSION_LESS "3")
+- find_package ( Lua51 ${_QUIET} )
+- if ( NOT LUA_FOUND )
+- find_package ( Lua50 ${_QUIET} )
+- endif()
+-else()
+- find_package ( Lua ${_QUIET} )
+-endif()
+-if ( LUA_FOUND )
++find_package ( Lua51 ${_QUIET} )
++if ( LUA51_FOUND )
+ set( WRAP_LUA_DEFAULT ON )
+ else()
+ set( WRAP_LUA_DEFAULT OFF )
diff --git a/python-package.patch b/python-package.patch
deleted file mode 100644
index 7d49349757f7..000000000000
--- a/python-package.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Wrapping/PythonVirtualEnvInstall.cmake.in 2015-09-29 00:00:08.000000000 +0800
-+++ b/Wrapping/PythonVirtualEnvInstall.cmake.in 2016-05-28 15:32:57.008424775 +0800
-@@ -5,10 +5,8 @@
-
- execute_process(
- COMMAND "@PYTHON_EXECUTABLE@"
-- "@SimpleITK_SOURCE_DIR@/Utilities/virtualenv/virtualenv.py"
-+ "/usr/bin/virtualenv"
- "--python=@PYTHON_EXECUTABLE@"
-- --no-pip
-- --no-setuptools
- --clear
- "@PythonVirtualenvHome@"
- RESULT_VARIABLE failed