summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD26
-rw-r--r--simplenote-electron-arm-bin.install20
3 files changed, 38 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ed71a2f84da..f1338606ae59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = simplenote-electron-arm-bin
pkgdesc = The simplest way to keep notes
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Automattic/simplenote-electron
+ install = simplenote-electron-arm-bin.install
arch = armv7h
arch = aarch64
license = GPL2
+ makedepends = zlib
depends = gtk3
+ depends = hicolor-icon-theme
depends = libxss
depends = nss
optdepends = libnotify: desktop notifications
diff --git a/PKGBUILD b/PKGBUILD
index a7b9d44d7312..2611c3698773 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,21 @@ pkgname=simplenote-electron-arm-bin
_pkgname=${pkgname%-electron-arm-bin}
pkgver=2.5.0
_appimage="simplenote-electron-${pkgver}-${CARCH}.AppImage"
-pkgrel=1
+pkgrel=2
pkgdesc='The simplest way to keep notes'
arch=('armv7h' 'aarch64')
url='https://github.com/Automattic/simplenote-electron'
license=('GPL2')
-depends=('gtk3' 'libxss' 'nss')
+depends=('gtk3' 'hicolor-icon-theme' 'libxss' 'nss')
optdepends=(
'libnotify: desktop notifications'
'noto-fonts-emoji: emoji support'
'ttf-joypixels: emoji support'
)
+makedepends=('zlib')
provides=('simplenote')
options=(!strip)
+install="$pkgname.install"
source_armv7h=("simplenote-electron-${pkgver}-armv7h.AppImage"::"${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-armv7l.AppImage")
source_aarch64=("simplenote-electron-${pkgver}-aarch64.AppImage"::"${url}/releases/download/v${pkgver}/Simplenote-linux-${pkgver}-arm64.AppImage")
noextract=($_appimage)
@@ -36,7 +38,8 @@ prepare() {
./$_appimage --appimage-extract
## Fix Permissions ##
- find squashfs-root -type d -exec chmod 755 {} \;
+ find squashfs-root -type d -exec chmod 0755 {} \;
+ find squashfs-root -type f -name '*.so' -exec chmod 0644 {} \;
## Modify Desktop File ##
sed -i \
@@ -53,19 +56,18 @@ package() {
cd "$srcdir"
## Create Installation Directory Structure ##
- install -dm755 "$pkgdir"/usr/bin
- install -dm755 "$pkgdir"/opt/$_pkgname
- install -dm755 "$pkgdir"/usr/share/icons
+ install -dm0755 "$pkgdir"/usr/bin
+ install -dm0755 "$pkgdir"/opt/$_pkgname
+ install -dm0755 "$pkgdir"/usr/share/{applications,icons}
## Install Icons ##
cp -RL squashfs-root/usr/share/icons/hicolor "$pkgdir"/usr/share/icons/
- ## Install Desktop File ##
- install -Dm644 squashfs-root/${_pkgname}.desktop -t "$pkgdir"/usr/share/applications/
-
## Move AppImage Contents to /opt/$_pkgname ##
cp -RLT squashfs-root "$pkgdir"/opt/$_pkgname
-
- ## Symlink /usr/bin Executable to /opt/$_pkgname ##
- ln -s /opt/$_pkgname/$_pkgname "$pkgdir"/usr/bin/$_pkgname
+
+ ## Remove Unneccessary Directories/Files ##
+ rm -rf "$pkgdir"/opt/$_pkgname/usr
+ rm "$pkgdir"/opt/$_pkgname/AppRun
+ rm "$pkgdir"/opt/$_pkgname/$_pkgname.png
}
diff --git a/simplenote-electron-arm-bin.install b/simplenote-electron-arm-bin.install
new file mode 100644
index 000000000000..020b7c7da089
--- /dev/null
+++ b/simplenote-electron-arm-bin.install
@@ -0,0 +1,20 @@
+### Vars ###
+_pkgname=simplenote
+
+### Post Install ###
+post_install() {
+ ## Symlink Files ##
+ ln -s \
+ "$pkgdir"/opt/$_pkgname/${_pkgname}.desktop \
+ "$pkgdir"/usr/share/applications/${_pkgname}.desktop
+ ln -s \
+ "$pkgdir"/opt/$_pkgname/$_pkgname \
+ "$pkgdir"/usr/bin/$_pkgname
+}
+
+### Post Remove ###
+post_remove() {
+ ## Remove Symlinks ##
+ rm "$pkgdir"/usr/share/applications/${_pkgname}.desktop
+ rm "$pkgdir"/usr/bin/$_pkgname
+}