summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD42
-rw-r--r--simplescreenrecorder-wlroots-git.install11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87bae8f1ec8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = simplescreenrecorder-wlroots-git
+ pkgdesc = Experimental fork of simplescreenrecorder with added Wayland support
+ pkgver = 0.3.11.r23.g4b288cb
+ pkgrel = 1
+ url = https://github.com/foxcpp/ssr-wlroots
+ install = simplescreenrecorder-wlroots-git.install
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ makedepends = wayland-protocols
+ depends = qt5-base
+ depends = qt5-x11extras
+ depends = ffmpeg
+ depends = alsa-lib
+ depends = libpulse
+ depends = jack
+ depends = libgl
+ depends = glu
+ depends = libx11
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ depends = wayland
+ provides = simplescreenrecorder
+ conflicts = simplescreenrecorder
+ conflicts = simplescreenrecorder-git
+ source = git+https://github.com/foxcpp/ssr-wlroots
+ md5sums = SKIP
+
+pkgname = simplescreenrecorder-wlroots-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b9491e22470
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Matthew Hague <matthewhague@zoho.com>
+# Maintainer: Max Mazurov <fox.cpp@disroot.org>
+# Based on PKGBUILD/install by: Maarten Baert <maarten-baert@hotmail.com>
+
+pkgname=simplescreenrecorder-wlroots-git
+pkgver=0.3.11.r23.g4b288cb
+pkgrel=1
+pkgdesc="Experimental fork of simplescreenrecorder with added Wayland support"
+arch=("x86_64")
+url="https://github.com/foxcpp/ssr-wlroots"
+license=("GPL3")
+depends=("qt5-base" "qt5-x11extras"
+ "ffmpeg" "alsa-lib" "libpulse" "jack" "libgl" "glu"
+ "libx11" "libxext" "libxfixes" "libxi"
+ "desktop-file-utils" "gtk-update-icon-cache"
+ "wayland")
+makedepends=("git" "cmake" "qt5-tools" "wayland-protocols")
+source=("git+https://github.com/foxcpp/ssr-wlroots")
+md5sums=("SKIP")
+conflicts=("simplescreenrecorder" "simplescreenrecorder-git")
+provides=("simplescreenrecorder")
+
+install=simplescreenrecorder-wlroots-git.install
+
+pkgver() {
+ cd ssr-wlroots
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+prepare() {
+ cd ssr-wlroots
+ mkdir -p build
+}
+build() {
+ cd ssr-wlroots/build
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" -DCMAKE_INSTALL_LIBDIR="lib" -DCMAKE_BUILD_TYPE=Release -DWITH_QT5=TRUE ..
+ make
+}
+package() {
+ cd ssr-wlroots/build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/simplescreenrecorder-wlroots-git.install b/simplescreenrecorder-wlroots-git.install
new file mode 100644
index 000000000000..5fc896fdc761
--- /dev/null
+++ b/simplescreenrecorder-wlroots-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -f usr/share/icons/hicolor
+ ldconfig
+}
+post_upgrade() {
+ post_install
+}
+post_remove() {
+ post_install
+}