summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97d68bf91219..057816d6c9cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = simpletools
pkgdesc = Handy command line tools for ntuple manipulation and analysis.
pkgver = 2.0v.e574cc8
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/cofitzpa/simpletools
arch = i686
arch = x86_64
license = GPL2
+ makedepends = boost
+ makedepends = root
+ depends = boost
depends = root
provides = simpletools
- options = !emptydirs
source = simpletools::git+https://github.com/cofitzpa/simpletools#commit=e574cc8
source = settings.cmake
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1e3dbb54b119..eb7f82a2650e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,27 @@
pkgname=simpletools
pkgver=2.0v.e574cc8
_commit=e574cc8
-pkgrel=4
+pkgrel=5
pkgdesc="Handy command line tools for ntuple manipulation and analysis."
arch=('i686' 'x86_64')
url="https://github.com/cofitzpa/simpletools"
license=('GPL2')
provides=('simpletools')
-depends=('root')
+makedepends=('boost' 'root')
+depends=('boost' 'root')
source=("${pkgname}::git+https://github.com/cofitzpa/simpletools#commit=${_commit}"
'settings.cmake')
sha256sums=('SKIP'
'540b86cd9997926026a5d277c819ae9c348bde7921158a78f3c676c855b6ab5e')
-options=('!emptydirs')
prepare() {
mkdir -p "${srcdir}/${pkgname}/build"
cd "${srcdir}/${pkgname}/build"
+
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
cmake -C "${srcdir}/settings.cmake" "${srcdir}/${pkgname}"
}
@@ -41,6 +45,5 @@ package() {
done
# install docs & license
- install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/simpletools/LICENSE"
install -Dm644 "${srcdir}/${pkgname}/README.md" "${pkgdir}/usr/share/doc/simpletools/README.md"
}